summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-04-20 15:16:39 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-04-20 15:36:14 -0400
commit58958bdaa5ee1537877d75ccce89ef3ca4749133 (patch)
tree6b34edcaea080acbeb3bf8c12b29a310b9132b45 /sci-mathematics
parentsci-libs/caffe2: VariableOrderWrong (diff)
downloadgentoo-58958bdaa5ee1537877d75ccce89ef3ca4749133.tar.gz
gentoo-58958bdaa5ee1537877d75ccce89ef3ca4749133.tar.bz2
gentoo-58958bdaa5ee1537877d75ccce89ef3ca4749133.zip
sci-mathematics/dunshire: add 0.1.3, drop 0.1.1-r4
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/dunshire/Manifest2
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.1-r4.ebuild38
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.3.ebuild26
3 files changed, 27 insertions, 39 deletions
diff --git a/sci-mathematics/dunshire/Manifest b/sci-mathematics/dunshire/Manifest
index 2687328babf2..04a34be725a7 100644
--- a/sci-mathematics/dunshire/Manifest
+++ b/sci-mathematics/dunshire/Manifest
@@ -1 +1 @@
-DIST dunshire-0.1.1.tar.gz 300878 BLAKE2B b0ed57e535313fbc653fdc7c8fd32fb98382db71dfe419e315f4b82fc4630e47757d74b9105e846b2eefaa7dcd93b12886eee341b11d0e8b562a52e480478e9a SHA512 5cdf8125d7fc1f76a483009392360e9e9088f9b58ca3f123d14e366421e831e4e7c8e17d367ba0430fb3cd61873cae7a004c903ff5417bfc9adecb7831681081
+DIST dunshire-0.1.3.tar.gz 52450 BLAKE2B 047f732daa7f2a53b8d24ea0aafdad3234aa5ee151a66f776ba22746d58b4b91a5047ba615978d4017e56345ac608fd1f537adef06f38b5a429276e284a88d02 SHA512 227d142347ad7b7eb5b283aaa94f457b20b686f40aa86b2a74057eed00d3d90e87fb4a0f32071db3bd73412489794a0b398a557f8194931a6e7d51ff442aa2b0
diff --git a/sci-mathematics/dunshire/dunshire-0.1.1-r4.ebuild b/sci-mathematics/dunshire/dunshire-0.1.1-r4.ebuild
deleted file mode 100644
index 517eaddf4641..000000000000
--- a/sci-mathematics/dunshire/dunshire-0.1.1-r4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python library to solve linear games over symmetric cones"
-HOMEPAGE="https://michael.orlitzky.com/code/dunshire/"
-
-LICENSE="AGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
-
-# Tests run on the build host? Bug #693916. There's one doctest that
-# uses a numpy matrix, sorry. That will be fixed in the next release.
-# Otherwise numpy is not needed; the required interfaces are provided
-# through cvxopt.
-BDEPEND="test? (
- ${RDEPEND}
- dev-python/numpy[${PYTHON_USEDEP}]
-)"
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- local DOCS=( doc/README.rst )
- distutils-r1_python_install_all
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/sci-mathematics/dunshire/dunshire-0.1.3.ebuild b/sci-mathematics/dunshire/dunshire-0.1.3.ebuild
new file mode 100644
index 000000000000..ac63ace2d98f
--- /dev/null
+++ b/sci-mathematics/dunshire/dunshire-0.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python library to solve linear games over symmetric cones"
+HOMEPAGE="https://michael.orlitzky.com/code/dunshire/"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
+DOCS=( doc/README.rst )
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests setup.py
+
+python_test() {
+ esetup.py test
+}