summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-11-26 01:23:48 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-11-26 01:36:58 +0100
commit5f92d9dc75cfdf34c9f3e43b608c07273f847c1e (patch)
treeae346a31d5f0a530b82e119085ce49714f866d3f /sci-mathematics
parentdev-python/pymediainfo: add 6.0.1, Py3.11 (diff)
downloadgentoo-5f92d9dc75cfdf34c9f3e43b608c07273f847c1e.tar.gz
gentoo-5f92d9dc75cfdf34c9f3e43b608c07273f847c1e.tar.bz2
gentoo-5f92d9dc75cfdf34c9f3e43b608c07273f847c1e.zip
sci-mathematics/coq: bump to 8.16.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/Manifest1
-rw-r--r--sci-mathematics/coq/coq-8.16.1.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index 799be072c0d9..522b40f83976 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -3,3 +3,4 @@ DIST coq-8.12.0.tar.gz 6774001 BLAKE2B dc1d6adf9d4bd50d46007fbf5fd43d1ea97b6b226
DIST coq-8.13.0.tar.gz 7010242 BLAKE2B bf9ec96b6698a2371be3164f65424a8ffb273252afc05e046267cae4265c1be71f89d0345f9e40ab3a93f5063080fd0224502cc0de808c7a0ddbb0edacab5fca SHA512 c355f0a9183f3669debd5f8f4ab96786215d0cccc37d1c2ac95a2d3c6115c8b0ee7ff7e23464b18444e2648ef3f8c221f0f3a28acf91199751cea2b74ee3fe8e
DIST coq-8.15.2.tar.gz 7222794 BLAKE2B 2f187982a56cb0a512af838ee321b245f9a44b0c32f5413aafcef8e5b7f933e9b05ba521c3e681a6c6973ca2b7ec5965a8b69b2febb978ce7cf246755187f656 SHA512 6a5487912dedb6e54145bf3f177a091cffe13429ba2f73db7c1cc241fe10e86340c968e19cefba7d680facce55f4e914cbd16a317264b109a6f9a01ec822a8c5
DIST coq-8.16.0.tar.gz 7397421 BLAKE2B 25b94002c4d1d1266ef948f0276df74d6a60c5b5100c7126232e0e33642be3ec14f33acfff5d0d5c17681676338374f694ca7c8c35200e522e480c3791f69dd8 SHA512 f324b68efcec0680a52c92d6e2fdd340a0e360e7d56d7fc3b4b781af3bec923d2fa2fdbb139b07d2253568a657a09c0d3da4cd5bdf984a6ab913e606056df4b3
+DIST coq-8.16.1.tar.gz 7401345 BLAKE2B fa6bbcd6b4ee29feaf7475f58193209afeae0bf8b6e3640f2f1cf40dfcee7d7f1fb3f371e8790b8d11c993b5f234e9175f1f5036a7286b7c6569720ddd3985f7 SHA512 e9c82f1a180c2e3946628e8e039999a1841397a5b4cd77f158de69876fa43b5c0f61ce76c510cc2b2f646a489110aea59da452b88ddd7850d1eab4105f1382f5
diff --git a/sci-mathematics/coq/coq-8.16.1.ebuild b/sci-mathematics/coq/coq-8.16.1.ebuild
new file mode 100644
index 000000000000..8f3da8dda4ab
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.16.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+inherit desktop dune
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk debug +ocamlopt"
+RESTRICT="test" # fails
+
+RDEPEND="
+ dev-ml/zarith:=
+ || (
+ dev-ml/num
+ <dev-lang/ocaml-4.09.0[ocamlopt?]
+ )
+ gtk? (
+ >=dev-ml/lablgtk-3.1.2:3=[sourceview,ocamlopt?]
+ >=dev-ml/lablgtk-sourceview-3.1.2:3=[ocamlopt?]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ >=dev-java/antlr-4.7:4
+ dev-python/antlr4-python3-runtime
+ dev-python/beautifulsoup4
+ dev-python/pexpect
+ dev-python/sphinx_rtd_theme
+ dev-python/sphinxcontrib-bibtex
+ dev-tex/latexmk
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-xetex
+ media-fonts/freefont
+ )
+"
+
+DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md CREDITS INSTALL.md README.md )
+
+src_configure() {
+ local myconf=(
+ -prefix /usr
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -docdir /usr/share/doc/${PF}
+ -datadir /usr/share/coq
+ -configdir /etc/xdg/${PN}
+ -with-doc $(usex doc)
+ )
+
+ use debug && myconf+=( -debug )
+ use ocamlopt || myconf+=( -byte-only )
+
+ if use gtk ; then
+ if use ocamlopt ; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+
+ echo "Configure options: ${myconf[@]}"
+ sh ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" VERBOSE=1 COQ_USE_DUNE="" world
+}
+
+src_test() {
+ emake STRIP="true" VERBOSE=1 COQ_USE_DUNE="" check
+}
+
+src_install() {
+ local sym
+ local syms=( coq-core coqide-server )
+
+ emake STRIP="true" VERBOSE=1 COQ_USE_DUNE="" DESTDIR="${D}" install-library
+ dune-install coq-core coqide-server
+
+ if use gtk ; then
+ dune-install coqide
+ make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+ syms+=( coqide )
+ fi
+
+ use doc && emake DESTDIR="${D}" install-doc-all
+ einstalldocs
+
+ # Dune installs into /usr/<libdir>/ocaml/<coq> but
+ # Coq wants /usr/<libdir>/<coq> ; symlink those directories
+ for sym in ${syms[@]} ; do
+ dosym $(ocamlc -where)/${sym} /usr/$(get_libdir)/${sym}
+ done
+}