summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-01-30 17:53:17 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-01-30 17:53:37 -0500
commit67c311a021cd0fd8eb6d4b950357f658f97691d4 (patch)
tree544d31ebe924c98a2d97e7ae352cfa474181dc67 /sci-mathematics
parentsys-devel/crossdev: Stabilize 20211121 sparc, #832375 (diff)
downloadgentoo-67c311a021cd0fd8eb6d4b950357f658f97691d4.tar.gz
gentoo-67c311a021cd0fd8eb6d4b950357f658f97691d4.tar.bz2
gentoo-67c311a021cd0fd8eb6d4b950357f658f97691d4.zip
sci-mathematics/polymake: new upstream release polymake-4.6.
Standard version bump, and we now explicitly disable OpenMP. The upstream pseudo-configure script tries to append -fopenmp to *FLAGS otherwise, causing build failures with non-OpenMP toolchains. OpenMP is used minimally by polymake itself; the real application is to its bundled libraries (that we unbundle). Closes: https://bugs.gentoo.org/832101 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/polymake/Manifest2
-rw-r--r--sci-mathematics/polymake/polymake-4.6.ebuild (renamed from sci-mathematics/polymake/polymake-4.5.ebuild)10
2 files changed, 8 insertions, 4 deletions
diff --git a/sci-mathematics/polymake/Manifest b/sci-mathematics/polymake/Manifest
index 913e6a1540b0..2405e7d77aa0 100644
--- a/sci-mathematics/polymake/Manifest
+++ b/sci-mathematics/polymake/Manifest
@@ -1 +1 @@
-DIST polymake-4.5-minimal.tar.bz2 5634046 BLAKE2B dc8a10885b23f8c690e9b8e36d6b55193bbc6d77d56c3b2facea70221860c33d2df58a8a693b9d43c0f613962ce2bd1b3258f1a558af8335297092a60876054a SHA512 07fcc9c20c4e48fc6d83845c50c12b2cadeaf55f74619985d21e252970ad76d6ee8cc528cd419e71ed5927d83758e5d6862e41c1610f93ea95127ad9115a333b
+DIST polymake-4.6-minimal.tar.bz2 5634651 BLAKE2B 6ee24fa6e70fdf746ea298d78e21e17fe38c5837ae2d3153e53656b4b003555b06897f463220b59474eed1111135dfa61c080d08d6363391afca51011f331122 SHA512 90f04c67bf297fb1b9f5a51d1654ff12385860b1fc80278a8b47f65970f11a1e0f33ede8a839b54a12422e772c8b76302ff78cc467712a2486f6e76ce0d5ab20
diff --git a/sci-mathematics/polymake/polymake-4.5.ebuild b/sci-mathematics/polymake/polymake-4.6.ebuild
index 750cfef6a60f..e82e8fe3f95b 100644
--- a/sci-mathematics/polymake/polymake-4.5.ebuild
+++ b/sci-mathematics/polymake/polymake-4.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -60,7 +60,7 @@ RESTRICT=test
src_configure() {
# Without this, the build system tries to use "the highest possible"
# optimization level and will override what's in your CXXFLAGS.
- export CXXOPT=$(get-flag -O)
+ export CXXOPT=""
tc-export CC CXX
@@ -71,7 +71,10 @@ src_configure() {
use bliss && append-cxxflags -DBLISS_USE_GMP
# This isn't an autotools ./configure script, so a lot of things
- # don't work the way you'd expect.
+ # don't work the way you'd expect. We disable openmp unconditionally
+ # because it's only supposedly only used for building the bundled
+ # libnormaliz (we unbundle it) and for something called to_simplex
+ # that I can't find anywhere in the polymake source.
./configure --prefix="${EPREFIX}/usr" \
--libdir="${EPREFIX}/usr/$(get_libdir)" \
--libexecdir="${EPREFIX}/usr/$(get_libdir)/polymake" \
@@ -81,6 +84,7 @@ src_configure() {
--without-native \
--without-scip \
--without-soplex \
+ --without-openmp \
$(use_with bliss bliss "${EPREFIX}/usr") \
$(use_with cdd cdd "${EPREFIX}/usr") \
$(use_with flint flint "${EPREFIX}/usr") \