summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2021-03-23 09:44:21 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-26 11:29:42 +0200
commit6f3cdaea4f8994d8c951171712aedc8c25eba0dc (patch)
tree367587fe80b047410b5be0cefd98f11639ccc0d9 /sci-mathematics
parentmedia-sound/strawberry: Added dev-qt/qttest:5 to DEPEND (diff)
downloadgentoo-6f3cdaea4f8994d8c951171712aedc8c25eba0dc.tar.gz
gentoo-6f3cdaea4f8994d8c951171712aedc8c25eba0dc.tar.bz2
gentoo-6f3cdaea4f8994d8c951171712aedc8c25eba0dc.zip
sci-mathematics/gimps: Version bump to 30.5 build 2
Closes: https://bugs.gentoo.org/777849 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gimps/Manifest2
-rw-r--r--sci-mathematics/gimps/gimps-30.5.2.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index 47960969c6e6..3aff6e1ed032 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -2,3 +2,5 @@ DIST p95v303b6.linux32.tar.gz 5702312 BLAKE2B 728c8b8e7e2b5187dc8126bccc5e2c165f
DIST p95v303b6.linux64.tar.gz 7046127 BLAKE2B 9cde9c2670203071cfc463434a47c8123064cb232bfeb25d8767cad2c25ea75b395e2ec135b7b4a6dc9616e9d6b05ead371e1083274a82468f62a0e1de93c98f SHA512 6d6ded9a1724993d42adee28d400b0337835c52a4ce42271e62efb37134adfc6f017f55475860fbc1224e377a227ef8547b8852a35c082c37e996f4a1c1b570c
DIST p95v305b1.linux32.tar.gz 5695975 BLAKE2B d2ab3724cf8743292533a7cb5c73b2fc6743c6e11507f92218b6b65f39e78c2f61147a6898d0a77fef590a0c989aa6f17d1984a6e4801594fbe4c3a7484d1750 SHA512 74e2592c1f3c4bb45cc076e35cd70d5c295d613ab142feb1c18138ea8816c21c56f5531c4938c49706bbb66f30ad84c5dd2f76f2184e1a1ea0de7423e941df52
DIST p95v305b1.linux64.tar.gz 7166108 BLAKE2B 60880e36ed618ad94aacd0f89811b72137fd27e99dff33b02286ea0f4778bce320c9b8da7b470fa491ea2e333f03d9d2994c2ea1513289acfc2f5b63695509fd SHA512 c38416b83850104d8d78191a4591fbef1bd356f8804725ccfdd7ebe065bc05ed86c09a128ac7824f809242712d60a1eb7ecb200358c1cde37fc4b7c13b82006f
+DIST p95v305b2.linux32.tar.gz 5695951 BLAKE2B d97f5b553e0a0563d51a08049c08fe31231e2689cfe6ec979b832603bace334755e947be2d7a106d4f4b807070568746f2cdabf869c5c4c6e125155c332b10bf SHA512 b5caa642e742438f10b5ee89d27213834755051679fe0d4d452e446b2f7628c8a874227971473d4319b8841f47a0bb32e7de9731d8b45e808356efb11922716e
+DIST p95v305b2.linux64.tar.gz 7165963 BLAKE2B 3ae20e8e29273650e94ff8774f973240c6b57d7a54e1674e7f741a9d366d3fdad98bb91b8e2abfcf7e1df6319476aa116e921171f2b585a568ee7d5038635531 SHA512 5fe250f7dcc35767fd5f4529219351095d1076f631528d80fa09498e27fa211abc621ef070548c398402143bec5e1d6e6e974155f50eb9f42af0ca179e4e03a8
diff --git a/sci-mathematics/gimps/gimps-30.5.2.ebuild b/sci-mathematics/gimps/gimps-30.5.2.ebuild
new file mode 100644
index 000000000000..7a7160c336ab
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-30.5.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="https://www.mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(ver_rs 2 'b' )
+
+SRC_URI="
+ amd64? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux64.tar.gz )
+ x86? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux32.tar.gz )
+ "
+
+SLOT="0"
+LICENSE="GIMPS"
+RESTRICT="mirror bindist"
+KEYWORDS="-* ~amd64 ~x86"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+OPTINSTALLDIR="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${OPTINSTALLDIR}
+ keepdir /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${OPTINSTALLDIR}" || die
+ fperms a-w "${OPTINSTALLDIR}/mprime"
+ fowners root:0 "${OPTINSTALLDIR}"
+ fowners root:0 "${OPTINSTALLDIR}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}