summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-04-02 11:08:51 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-04-02 11:09:40 -0400
commit7876a356f737310c0cdda056fb77ebcbab866f3d (patch)
tree654150731160c616208b1c91a33ef0514edb64d1 /sci-mathematics
parentdev-db/pg_activity: version bump to 3.5.0 (diff)
downloadgentoo-7876a356f737310c0cdda056fb77ebcbab866f3d.tar.gz
gentoo-7876a356f737310c0cdda056fb77ebcbab866f3d.tar.bz2
gentoo-7876a356f737310c0cdda056fb77ebcbab866f3d.zip
sci-mathematics/singular: backport strict-aliasing/lto fix
Bug: https://bugs.gentoo.org/927675 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/singular/files/singular-4.3.2_p16-lto.patch18
-rw-r--r--sci-mathematics/singular/singular-4.3.2_p16.ebuild11
2 files changed, 20 insertions, 9 deletions
diff --git a/sci-mathematics/singular/files/singular-4.3.2_p16-lto.patch b/sci-mathematics/singular/files/singular-4.3.2_p16-lto.patch
new file mode 100644
index 000000000000..a880f4ef5b12
--- /dev/null
+++ b/sci-mathematics/singular/files/singular-4.3.2_p16-lto.patch
@@ -0,0 +1,18 @@
+From 83a4e40c59dd99ff3131cbdb57b24b456aa04b93 Mon Sep 17 00:00:00 2001
+From: Hans Schoenemann <hannes@mathematik.uni-kl.de>
+Date: Tue, 2 Apr 2024 15:09:51 +0200
+Subject: [PATCH] countedref + https://github.com/Singular/Singular/issues/1212
+
+diff --git a/Singular/countedref.cc b/Singular/countedref.cc
+index d3b783ade7..f83d7fab62 100644
+--- a/Singular/countedref.cc
++++ b/Singular/countedref.cc
+@@ -108,7 +108,7 @@ class CountedRefData:
+ BOOLEAN put(leftv res) { return broken() || m_data.put(res); }
+
+ /// Extract (shallow) copy of stored data
+- LeftvShallow operator*() const { return (broken()? LeftvShallow(): (const LeftvShallow&)m_data); }
++ LeftvShallow operator*() { return (broken()? LeftvShallow(): LeftvShallow(m_data)); }
+
+ /// Determine active ring when ring dependency changes
+ BOOLEAN rering() {
diff --git a/sci-mathematics/singular/singular-4.3.2_p16.ebuild b/sci-mathematics/singular/singular-4.3.2_p16.ebuild
index 1b8fee9d38a1..94a83c7da0c8 100644
--- a/sci-mathematics/singular/singular-4.3.2_p16.ebuild
+++ b/sci-mathematics/singular/singular-4.3.2_p16.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common flag-o-matic
+inherit autotools elisp-common
MY_PN=Singular
MY_PV=$(ver_rs 3 '')
@@ -42,6 +42,7 @@ SITEFILE=60${PN}-gentoo.el
PATCHES=(
"${FILESDIR}/${P}-test-underlinking.patch"
+ "${FILESDIR}/${P}-lto.patch"
)
src_prepare() {
@@ -50,14 +51,6 @@ src_prepare() {
}
src_configure() {
- # -Werror=strict-aliasing
- # https://bugs.gentoo.org/927675
- # https://github.com/Singular/Singular/issues/1212
- #
- # Do not trust with LTO either.
- append-flags -fno-strict-aliasing
- filter-lto
-
local myconf=(
--disable-debug
--disable-doc