summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-25 09:39:50 +0000
committerSam James <sam@gentoo.org>2021-04-25 09:39:57 +0000
commit7fdecd2623e3ced4f9bc834c7ff1dad1a44ce3a3 (patch)
treee1453c922ee48173e14e013c91727dc50fdedd3a /sci-mathematics
parentsci-mathematics/wxmaxima: run unit tests manually (diff)
downloadgentoo-7fdecd2623e3ced4f9bc834c7ff1dad1a44ce3a3.tar.gz
gentoo-7fdecd2623e3ced4f9bc834c7ff1dad1a44ce3a3.tar.bz2
gentoo-7fdecd2623e3ced4f9bc834c7ff1dad1a44ce3a3.zip
sci-mathematics/wxmaxima: add 21.04.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-21.04.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 3ce40b0e5090..ec34396b1e5b 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxmaxima-18.11.4.tar.gz 12156776 BLAKE2B 75be0fb88402af011885616a646f7abcad25516ea9b0b375daf02edac5518b113188290262bc431e8bfb4836fc1f731982a1c41c62871818e4d2cc68c96ccb31 SHA512 964de93edc5c46e98de3de405b1873fa0ed594d54f1ddc030377b023110261cb1e6b0b08dbf210551888bf890e28d16e9b1698768c93dde413d5e1918cbd234e
DIST wxmaxima-20.12.2.tar.gz 16262617 BLAKE2B 2f9f910f565158b2011f014d96747498c6286a95bdb69f9b6b2f82a37a569e8a02abbae5cbb9ae2ac1e78d0b976487666794b267c1c40c1245df08c752486403 SHA512 1c3e3f68a2fa2cd798dfb05c52e7ddf3193a15cb45282553c280914bd524d463ad27acc89898cb4a292ff236699d1ec2abb70d83fa52cb126123ab8e2fcd5ceb
DIST wxmaxima-21.01.0.tar.gz 16220587 BLAKE2B b987e8c44c253484d152092093ab9154b7c2a5817c584bc1a4f4a0e5beec3ec2e0bc6995aea6ba28df2223b039ca97905225cc2524840174b2c99a5f7774dab2 SHA512 aec5aa5d3a9883e9b21b890c133684004576411a8341f3913ae548175979ad1f07a16d0fccd24c7757d40f4d06b4070b00fa7ef54f73f26b99c825e03e2a408b
+DIST wxmaxima-21.04.0.tar.gz 17684730 BLAKE2B a3b12970ad976a3ee3fc237b6d60f52d460e87997b869825d17645daa0f82bcc6f7999188fe4c92bba819d7a895cff468ff273ab62ab30f38a7a54a6dba47786 SHA512 723373c9fd9877bce38a205455e6ac58a48a61ac3ad0be5c09d0b24abeebd35af481f19efe5de08a2507f1198a8b4b6cfa987c50e4d4a580b4e05ec2c3e5a4f7
diff --git a/sci-mathematics/wxmaxima/wxmaxima-21.04.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-21.04.0.ebuild
new file mode 100644
index 000000000000..72cf6098d523
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-21.04.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake wxwidgets l10n xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ l10n_find_plocales_changes locales/wxMaxima '' '.po'
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}