summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-31 12:17:20 +0200
committerDavid Seifert <soap@gentoo.org>2021-03-31 12:17:20 +0200
commit81f08ed7814eb869dda2851efca433df263ed87e (patch)
tree1f064c7b5f261116a164e3fba4419a87583b2eae /sci-mathematics
parentsci-mathematics/msieve: Clean up ebuild (diff)
downloadgentoo-81f08ed7814eb869dda2851efca433df263ed87e.tar.gz
gentoo-81f08ed7814eb869dda2851efca433df263ed87e.tar.bz2
gentoo-81f08ed7814eb869dda2851efca433df263ed87e.zip
sci-mathematics/msieve: Remove broken live ebuild
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/msieve/msieve-9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/sci-mathematics/msieve/msieve-9999.ebuild b/sci-mathematics/msieve/msieve-9999.ebuild
deleted file mode 100644
index 72fa0aaf997f..000000000000
--- a/sci-mathematics/msieve/msieve-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils subversion toolchain-funcs
-
-DESCRIPTION="A C library implementing a suite of algorithms to factor large integers"
-HOMEPAGE="https://sourceforge.net/projects/msieve/"
-#SRC_URI="mirror://sourceforge/${PN}/${PN}/Msieve%20v${PV}/${PN}${PV/./}src.tar.gz"
-ESVN_REPO_URI="https://svn.code.sf.net/p/msieve/code/trunk"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS=""
-IUSE="zlib +ecm mpi"
-
-DEPEND="
- ecm? ( sci-mathematics/gmp-ecm )
- mpi? ( virtual/mpi )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # TODO: Integrate ggnfs properly
- sed -i -e 's/-march=k8//' Makefile || die
- sed -i -e 's/CC =/#CC =/' Makefile || die
- sed -i -e 's/CFLAGS =/CFLAGS +=/' Makefile || die
-}
-
-src_compile() {
- use ecm && export "ECM=1"
- use mpi && export "MPI=1"
- use zlib && export "ZLIB=1"
- emake \
- CC=$(tc-getCC) \
- AR=$(tc-getAR) \
- OPT_FLAGS="${CFLAGS}" \
- all
-}
-
-src_install() {
- mkdir -p "${D}/usr/include/msieve"
- mkdir -p "${D}/usr/lib/"
- mkdir -p "${D}/usr/share/doc/${P}/"
- cp include/* "${D}/usr/include/msieve" || die "Failed to install"
- cp libmsieve.a "${D}/usr/lib/" || die "Failed to install"
- dobin msieve
- cp Readme* "${D}/usr/share/doc/${P}/" || die "Failed to install"
-}