summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-06-08 07:13:34 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-06-08 07:13:34 -0400
commit87e89d0d485abbd8b782d848577d6f3f1c02febd (patch)
tree02233ff88ea0eaf46e812ee2b3f97e81d8aa8468 /sci-mathematics
parentwww-client/firefox: stabilize 102.12.0 for amd64 (diff)
downloadgentoo-87e89d0d485abbd8b782d848577d6f3f1c02febd.tar.gz
gentoo-87e89d0d485abbd8b782d848577d6f3f1c02febd.tar.bz2
gentoo-87e89d0d485abbd8b782d848577d6f3f1c02febd.zip
sci-mathematics/singular: drop 4.3.1_p1
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/singular/Manifest1
-rw-r--r--sci-mathematics/singular/singular-4.3.1_p1.ebuild103
2 files changed, 0 insertions, 104 deletions
diff --git a/sci-mathematics/singular/Manifest b/sci-mathematics/singular/Manifest
index e25fe781af5c..de3e9b299b1a 100644
--- a/sci-mathematics/singular/Manifest
+++ b/sci-mathematics/singular/Manifest
@@ -1,3 +1,2 @@
-DIST singular-4.3.1p1.tar.gz 15090370 BLAKE2B d4e40378b3892b98b1f78c3928c8a40484336ea25ea4dcd4b3a1e5f651281d2cdb06d92c9cc64427ce76e91c5bf4eaa1c3b643df174a24c188823ae808817ad9 SHA512 d27d8e042ea085e49aed6a0697056c36e78e62ea0b9d17751cdf4c556cf4f6efce3b34b411c77aef97c6d90675bea11c97651eb7009634cb8a9b630ec820a06e
DIST singular-4.3.1p3.tar.gz 14991986 BLAKE2B 0ae2585a362839914d3a134bfe637f6faa34d95f58937f2adcca0c5a35e3218eb36554bae8187f5bb3a423dcac445c836e9bfff2d0d1a19d4e14a4452b84d839 SHA512 f092683f4a92158d82a2e694f284662c6285bac5faaa7d5e5695a84a220012fb8a733b4bbc52820def3037e1596ea4c2ab3846f58a3a3fb19e01bf7595790462
DIST singular-4.3.2p1.tar.gz 15013729 BLAKE2B 00276f2417cd9e2b71afcae66c2aeb7f9d4f434f5a90deeee56dded66e6d5e0020ab0b06b6561e41f5b196262993732ffeb9196f59315f1b6a081b0029fc99a1 SHA512 451054a0bf33b9d1c94a63f0946e1eb7b3e7b92bc025b6aa4f64e65183aeebd6354bac5f87f6e8b35cb713b30e97af5c66f92f02683144bb426f5e3a828db616
diff --git a/sci-mathematics/singular/singular-4.3.1_p1.ebuild b/sci-mathematics/singular/singular-4.3.1_p1.ebuild
deleted file mode 100644
index 580a93422a2e..000000000000
--- a/sci-mathematics/singular/singular-4.3.1_p1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common
-
-MY_PN=Singular
-MY_PV=$(ver_rs 3 '')
-# Consistency is different...
-MY_DIR2=$(ver_cut 1-3 ${PV})
-MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
-
-DESCRIPTION="Computer algebra system for polynomial computations"
-HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Singular"
-SRC_URI="ftp://jim.mathematik.uni-kl.de/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_DIR2}"
-
-LICENSE="BSD GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~riscv x86 ~x86-linux"
-IUSE="emacs examples polymake +readline static-libs"
-
-RDEPEND="
- dev-lang/perl
- dev-libs/gmp:0
- dev-libs/ntl:=
- sci-libs/cddlib
- sci-mathematics/flint
- emacs? ( >=app-editors/emacs-23.1:* )
- polymake? ( sci-mathematics/polymake )
- readline? ( sys-libs/readline )
-"
-DEPEND="${RDEPEND}"
-
-SITEFILE=60${PN}-gentoo.el
-
-src_configure() {
- local myconf=(
- --disable-debug
- --disable-doc
- --disable-optimizationflags
- --disable-pyobject-module
- --disable-python
- --disable-python-module
- --disable-python_module
- --enable-factory
- --enable-gfanlib
- --enable-libfac
- --with-flint
- --with-gmp
- --with-libparse
- --with-ntl
- --without-python
- --without-pythonmodule
- $(use_enable emacs)
- $(use_enable polymake polymake-module)
- $(use_enable static-libs static)
- $(use_with readline)
- )
- econf "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- if use emacs; then
- pushd "${S}"/emacs
- elisp-compile *.el || die "elisp-compile failed"
- popd
- fi
-}
-
-src_install() {
- # Do not compress singular's info file (singular.hlp)
- # some consumer of that file do not know how to deal with compression
- docompress -x /usr/share/info
-
- default
-
- dosym Singular /usr/bin/"${PN}"
-
- # purge .la file
- find "${ED}" -name '*.la' -delete || die
-}
-
-src_test() {
- # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
- # an already installed version of singular may be used and cause segfault
- # See https://github.com/Singular/Sources/issues/980
- SINGULAR_PROCS_DIR="" emake check
-}
-
-pkg_postinst() {
- einfo "Additional functionality can be enabled by installing"
- einfo "sci-mathematics/4ti2"
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}