summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-08 11:08:20 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-08 11:31:26 +0100
commit8ff0e296c5d8d13e5b0a284f37b710190e0f870a (patch)
treebc030874a66d97ed13b1a516cb7b3d0607d35fe9 /sci-mathematics
parentsci-mathematics/cadical: drop old 1.5.3-r1 (diff)
downloadgentoo-8ff0e296c5d8d13e5b0a284f37b710190e0f870a.tar.gz
gentoo-8ff0e296c5d8d13e5b0a284f37b710190e0f870a.tar.bz2
gentoo-8ff0e296c5d8d13e5b0a284f37b710190e0f870a.zip
sci-mathematics/cadical: bump to 1.9.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cadical/Manifest1
-rw-r--r--sci-mathematics/cadical/cadical-1.9.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/cadical/Manifest b/sci-mathematics/cadical/Manifest
index d8c5a341fe91..2f114b6f8ecd 100644
--- a/sci-mathematics/cadical/Manifest
+++ b/sci-mathematics/cadical/Manifest
@@ -1 +1,2 @@
DIST cadical-1.8.0.tar.gz 649017 BLAKE2B 73db2dd0278869bc1b4fe5d1eb80e767a07c640bcd2b1901d86901a09ac6b8bdbe375017593c12ac80d7a860a0aead191777ce733452741395bf14b958bd1b03 SHA512 78dfd4a4a93090e3e00fa73c0dfde6edc781e8a69f257506f273cac46b942979335c2ae0ac1054bde68259b030ba235615275307ad077762c8770884914cfed7
+DIST cadical-1.9.4.tar.gz 691203 BLAKE2B 40fcb86e60b2c6e4f24d43976e12ae063aa00ccfc8cad78d27e85b863b0faee23213d210886fd2f374aa93b575b741fd079351d3655ee1ed5bb17f96cd0005b6 SHA512 a3477ac3a4ddcb8bb797653efa9afe992a84db94900394d401667a55630932a91e847fc943bf5509d6672523818233c247db0be4268b9d8aae1636bad1877bc3
diff --git a/sci-mathematics/cadical/cadical-1.9.4.ebuild b/sci-mathematics/cadical/cadical-1.9.4.ebuild
new file mode 100644
index 000000000000..4c087365b45b
--- /dev/null
+++ b/sci-mathematics/cadical/cadical-1.9.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Satisfiability Solver"
+HOMEPAGE="http://fmv.jku.at/cadical/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/arminbiere/${PN}.git"
+else
+ SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-rel-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-configure.patch"
+ "${FILESDIR}/${PN}-makefile.in-ar.patch"
+)
+
+DOCS=( CONTRIBUTING.md NEWS.md README.md )
+
+src_configure() {
+ tc-export AR
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe build/{cadical,mobical}
+
+ dolib.a build/libcadical.a
+ doheader src/cadical.hpp
+ doheader src/ccadical.h
+
+ einstalldocs
+}