summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-08-22 11:03:27 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-08-22 11:05:32 -0400
commit988e3ef2f9cd8d54659fc4dc3df9b8fb078429b2 (patch)
treeda0912c55912a1e1362707677610c7c1d83994ef /sci-mathematics
parentsci-mathematics/primesieve: add 8.0 (diff)
downloadgentoo-988e3ef2f9cd8d54659fc4dc3df9b8fb078429b2.tar.gz
gentoo-988e3ef2f9cd8d54659fc4dc3df9b8fb078429b2.tar.bz2
gentoo-988e3ef2f9cd8d54659fc4dc3df9b8fb078429b2.zip
sci-mathematics/primecount: add 7.4
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/primecount/Manifest1
-rw-r--r--sci-mathematics/primecount/primecount-7.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-mathematics/primecount/Manifest b/sci-mathematics/primecount/Manifest
index 658be43dc959..d9f757a35818 100644
--- a/sci-mathematics/primecount/Manifest
+++ b/sci-mathematics/primecount/Manifest
@@ -1 +1,2 @@
DIST primecount-7.3.tar.gz 360921 BLAKE2B 0d9ad7c791dba12b05e4c88703dc4bfc1f557a1443c8430f3921f1a6e99b740b437cb53f39e832d69c4148b597960b028e0f38e4f4d96e50434b1d020f4ea620 SHA512 56dcae60460c88368214e01f8e3618e6b61b13f2730bfd1f281721ef71d6136308ba6832e4bd25a1885e2c6142009c5772d6102f82c65e8522e990cb62c55e71
+DIST primecount-7.4.tar.gz 372374 BLAKE2B ca16004e1a1fe209452d1c4aa9d4dfe7816ff581ffbb9717ae9a8224815df0b672871ec3d749000099a91c8ee50bcc3c43cea3dcb9ff999436544bed2c2f5fde SHA512 20b33a1c0d2338f422a0da8723bafd35689f9c93918c7dcf64068aee1cd5e03f41d0ef49e39a7e920828b478e8faeda4fea477dacca1145c852f24d1f5e6ab5b
diff --git a/sci-mathematics/primecount/primecount-7.4.ebuild b/sci-mathematics/primecount/primecount-7.4.ebuild
new file mode 100644
index 000000000000..b96647e98b8f
--- /dev/null
+++ b/sci-mathematics/primecount/primecount-7.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Highly optimized CLI and library to count primes"
+HOMEPAGE="https://github.com/kimwalisch/primecount"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/7" # subslot is first component of libprimecount.so version
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_popcnt +executable openmp test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=sci-mathematics/primesieve-8.0:="
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/Credits.md
+ doc/Easy-Special-Leaves.md
+ doc/Hard-Special-Leaves.md
+ doc/Records.md
+ doc/References.md
+ doc/alpha-factor-dr.pdf
+ doc/alpha-factor-gourdon.pdf
+ doc/alpha-factor-lmo.pdf
+ doc/libprimecount.md
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_LIBPRIMESIEVE="OFF"
+ -DBUILD_PRIMECOUNT="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ -DWITH_OPENMP="$(usex openmp)"
+ -DWITH_POPCNT="$(usex cpu_flags_x86_popcnt)"
+ )
+
+ cmake_src_configure
+}