summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-03-25 20:55:42 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-03-25 20:55:42 +0700
commit9b7b496428d9e3c307666e05aed3035c0ebb883d (patch)
treea07ed7473f96bb254f954b1b90d9cd0fec72e49a /sci-mathematics
parentnet-wireless/unifi: bump to 6.1.71 (diff)
downloadgentoo-9b7b496428d9e3c307666e05aed3035c0ebb883d.tar.gz
gentoo-9b7b496428d9e3c307666e05aed3035c0ebb883d.tar.bz2
gentoo-9b7b496428d9e3c307666e05aed3035c0ebb883d.zip
sci-mathematics/maxima: don't hardcode python
Suggested-by: Michael Orlitzky <mjo@gentoo.org> Closes: https://bugs.gentoo.org/766291 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/files/python-0.patch38
-rw-r--r--sci-mathematics/maxima/maxima-5.44.0.ebuild4
2 files changed, 40 insertions, 2 deletions
diff --git a/sci-mathematics/maxima/files/python-0.patch b/sci-mathematics/maxima/files/python-0.patch
new file mode 100644
index 000000000000..63dea1ea1de7
--- /dev/null
+++ b/sci-mathematics/maxima/files/python-0.patch
@@ -0,0 +1,38 @@
+From a640c5e357ce2aafb6edcba9b6c641cbc7753880 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 24 Mar 2021 20:57:44 -0400
+Subject: [PATCH 1/1] doc/info/build_html.sh.in: use @PYTHON@ for the python
+ interpreter.
+
+Maxima's ./configure script already detects (or is prodded to use) a
+certain python interpreter. The build_html.sh script, however, is
+still using a hard-coded "python" command. On many systems, "python"
+will be different from the python interpreter that we want to use; for
+example when "python" is python-2.7.x and "python3" is what we want to
+use with Maxima.
+
+This commit tweaks doc/info/build_html.sh.in to use the value of the
+$PYTHON variable instead.
+
+Maxima-Bug: https://sourceforge.net/p/maxima/bugs/3754
+Gentoo-Bug: https://bugs.gentoo.org/766291
+---
+ doc/info/build_html.sh.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/doc/info/build_html.sh.in b/doc/info/build_html.sh.in
+index 37930e9..c10e38d 100755
+--- a/doc/info/build_html.sh.in
++++ b/doc/info/build_html.sh.in
+@@ -46,7 +46,7 @@ do
+ echo "filenamebase = \"$filenamebase\""
+ cat $f
+ done | @AWK@ '!/^@c / && !/^@c$/ && (/^@deffn/ || /^@defvr/ || /^@end deffn/ || /^@end defvr/ || /@category/ || /@node/ || /^filenamebase/)' | @SED@ -f @abs_srcdir@/extract_categories1.sed | @AWK@ -f @abs_srcdir@/extract_categories1.awk > make-categories.py
+-python make-categories.py
++@PYTHON@ make-categories.py
+ @SED@ -e 's/^@bye/@node Documentation Categories, , Function and Variable Index\n@chapter Documentation Categories/' @abs_srcdir@/maxima.texi > maxima.texi
+ ( for f in Category-*.texi; do echo '@include' $f; done ; echo @bye ) >> maxima.texi
+
+--
+2.26.2
+
diff --git a/sci-mathematics/maxima/maxima-5.44.0.ebuild b/sci-mathematics/maxima/maxima-5.44.0.ebuild
index 6588716b4947..da0d520a076e 100644
--- a/sci-mathematics/maxima/maxima-5.44.0.ebuild
+++ b/sci-mathematics/maxima/maxima-5.44.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -97,7 +97,7 @@ pkg_setup() {
src_prepare() {
local n PATCHES v
- PATCHES=( emacs-0 rmaxima-0 wish-2 xdg-utils-1 )
+ PATCHES=( emacs-0 rmaxima-0 wish-2 xdg-utils-1 python-0 )
n=${#PATCHES[*]}
for ((n--; n >= 0; n--)); do