summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2021-03-27 16:28:03 -0400
committerMatthias Maier <tamiko@gentoo.org>2021-04-07 21:05:28 -0500
commitac15ac48507f43efe4d1be38e13ca1a4b35efaa6 (patch)
tree9995e261f201be5e219a292b8fbb67e0448f3c0f /sci-mathematics
parentwww-client/qutebrowser: upgrade 2.1.0 -> 2.1.1 (diff)
downloadgentoo-ac15ac48507f43efe4d1be38e13ca1a4b35efaa6.tar.gz
gentoo-ac15ac48507f43efe4d1be38e13ca1a4b35efaa6.tar.bz2
gentoo-ac15ac48507f43efe4d1be38e13ca1a4b35efaa6.zip
sci-mathematics/dsfmt: initial import
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/dsfmt/Manifest1
-rw-r--r--sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild36
-rw-r--r--sci-mathematics/dsfmt/metadata.xml17
3 files changed, 54 insertions, 0 deletions
diff --git a/sci-mathematics/dsfmt/Manifest b/sci-mathematics/dsfmt/Manifest
new file mode 100644
index 000000000000..a3eb8fdb3270
--- /dev/null
+++ b/sci-mathematics/dsfmt/Manifest
@@ -0,0 +1 @@
+DIST dsfmt-2.2.4.tar.gz 4984255 BLAKE2B 6119445d93cb45faab28dfb52a18c07cd5703b243b3cddde35fff7a5e948fa8788dfe8428ae8e0a52604f91ac07fe7b3bb0f6c438ef93b5257b42baee9dfdec5 SHA512 fe84e986cbf198172340adfac0436b08f087643eca3f1ceccacde146cbfd8c41e3eb0dfbb062f7ca5f462db13c386abd7c269bc0cbefc9a0ecf97a8a8870a2e4
diff --git a/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild b/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
new file mode 100644
index 000000000000..5de399e78f8a
--- /dev/null
+++ b/sci-mathematics/dsfmt/dsfmt-2.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MYPN=dSFMT
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Double precision SIMD-oriented Fast Mersenne Twister library"
+HOMEPAGE="http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT"
+SRC_URI="https://github.com/MersenneTwister-Lab/dSFMT/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${MYP}"
+
+soname="lib${MYPN}.so"
+
+src_compile() {
+ emake CCFLAGS="${CFLAGS}"
+ $(tc-getCC) -fPIC -shared -DDSFMT_SHLIB -DDSFMT_DO_NOT_USE_OLD_NAMES ${LDFLAGS} ${CFLAGS} -Wl,-soname=${soname} -o ${soname} ${MYPN}.c || die
+}
+
+src_test() {
+ emake std-check
+}
+
+src_install() {
+ doheader dSFMT.c d*.h
+ dodoc README*txt CHANGE*
+ dolib.so ${soname}
+}
diff --git a/sci-mathematics/dsfmt/metadata.xml b/sci-mathematics/dsfmt/metadata.xml
new file mode 100644
index 000000000000..736cfc4dcf52
--- /dev/null
+++ b/sci-mathematics/dsfmt/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The purpose of Double precision SIMD-oriented Fast Mersenne Twister (dSFMT)
+ is to speed up the generation by avoiding the expensive conversion
+ of integer to double (floating point). dSFMT directly generates
+ double precision floating point pseudorandom numbers which have the
+ IEEE Standard for Binary Floating-Point Arithmetic (ANSI/IEEE Std
+ 754-1985) format. dSFMT is only available on the CPUs which use IEEE
+ 754 format double precision floating point numbers.
+ </longdescription>
+</pkgmetadata>