summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-08 05:12:58 +0000
committerSam James <sam@gentoo.org>2023-01-08 05:17:26 +0000
commitb33a038cbac1a238d184e8c387b2b6fc7a7d6150 (patch)
tree863117522345b7eb2f9dbcfbbebfa688a133b5a2 /sci-mathematics
parentsci-mathematics/octave: drop 6.4.0-r3 (diff)
downloadgentoo-b33a038cbac1a238d184e8c387b2b6fc7a7d6150.tar.gz
gentoo-b33a038cbac1a238d184e8c387b2b6fc7a7d6150.tar.bz2
gentoo-b33a038cbac1a238d184e8c387b2b6fc7a7d6150.zip
sci-mathematics/octave: disable GLIBCXX_ASSERTIONS (libstdc++ bug)
It's not a test-only issue so could cause SIGABRT at runtime, so revbump. The libstdc++ issue is reported upstream at https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107538. Closes: https://bugs.gentoo.org/887815 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/octave-6.4.0-r5.ebuild (renamed from sci-mathematics/octave/octave-6.4.0-r4.ebuild)5
-rw-r--r--sci-mathematics/octave/octave-7.3.0-r2.ebuild (renamed from sci-mathematics/octave/octave-7.3.0-r1.ebuild)7
2 files changed, 9 insertions, 3 deletions
diff --git a/sci-mathematics/octave/octave-6.4.0-r4.ebuild b/sci-mathematics/octave/octave-6.4.0-r5.ebuild
index 4bc8ceb0934f..b3eb587fad29 100644
--- a/sci-mathematics/octave/octave-6.4.0-r4.ebuild
+++ b/sci-mathematics/octave/octave-6.4.0-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -119,6 +119,9 @@ src_prepare() {
}
src_configure() {
+ # libstdc++ bug, bug #887815
+ append-cxxflags -U_GLIBCXX_ASSERTIONS
+
# unfortunate dependency on mpi from hdf5 (bug #302621)
use hdf5 && has_version sci-libs/hdf5[mpi] && \
export CXX=mpicxx CC=mpicc FC=mpif77 F77=mpif77
diff --git a/sci-mathematics/octave/octave-7.3.0-r1.ebuild b/sci-mathematics/octave/octave-7.3.0-r2.ebuild
index 50d77f9706b7..2d09264e6440 100644
--- a/sci-mathematics/octave/octave-7.3.0-r1.ebuild
+++ b/sci-mathematics/octave/octave-7.3.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools fortran-2 java-pkg-opt-2 pax-utils qmake-utils toolchain-funcs xdg
+inherit autotools flag-o-matic fortran-2 java-pkg-opt-2 pax-utils qmake-utils toolchain-funcs xdg
DESCRIPTION="High-level interactive language for numerical computations"
HOMEPAGE="https://www.gnu.org/software/octave/"
@@ -144,6 +144,9 @@ src_prepare() {
}
src_configure() {
+ # libstdc++ bug, bug #887815
+ append-cxxflags -U_GLIBCXX_ASSERTIONS
+
# Unfortunate dependency on mpi from hdf5 (bug #302621)
use hdf5 && has_version sci-libs/hdf5[mpi] && \
export CXX=mpicxx CC=mpicc FC=mpif77 F77=mpif77