summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-09-27 15:44:50 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-09-27 15:44:50 +0700
commitb517cbb816e26ed270e25a5b3c2408b4fc019c8f (patch)
tree1949933925cc6f662335a83f1624a68dfd94c69b /sci-mathematics
parentdev-util/mingw64-toolchain: drop 10.0.0-r2 (diff)
downloadgentoo-b517cbb816e26ed270e25a5b3c2408b4fc019c8f.tar.gz
gentoo-b517cbb816e26ed270e25a5b3c2408b4fc019c8f.tar.bz2
gentoo-b517cbb816e26ed270e25a5b3c2408b4fc019c8f.zip
sci-mathematics/wxmaxima: bump to 22.09.0
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-22.09.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index e3ae308cc5d7..a50a231da3c5 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -2,3 +2,4 @@ DIST wxmaxima-20.12.2.tar.gz 16262617 BLAKE2B 2f9f910f565158b2011f014d96747498c6
DIST wxmaxima-21.11.0.tar.gz 15982803 BLAKE2B 8eff24b3b08fd156341cbd1c565fd832277f99cbbfa2f166671502399e8658273dca86c48b3b09c8616b9d9a17ec4ea9230def645719bcf3c22fc410f5f31d62 SHA512 1660537d475dc16e6d25011ae02b50a9179dd97b19dd115e914636fac71684906d77a2e4f4ab2d8506ac9f6b297de8feeeb46489a6dbf5782783f890a4181506
DIST wxmaxima-22.04.0.tar.gz 21477753 BLAKE2B aad35f628b2b74d41a7cb501d5e98c59b8588103f729fc39e901c50416a17bd296c4959f2276728a2654924bd16dd7416ef39b69eb01c5c05ee857f69ea1d42d SHA512 5197dab483012b39e910208406f32f2892d9acc3c0abc8582a61a43fad4f13e95692f8e499a2d0ca1680ca2ca48ea4c4853aa04c3f18d5e3a923c11316ebbf62
DIST wxmaxima-22.05.0.tar.gz 21493488 BLAKE2B 0b1f4bd65e88e4f39d5d54f164373ca67a76bd2a18a1556cd4b86cdb5a62ca3f0c783c6e1725ec1006f6174163f08b7b934dcfa3fd8a8a7aa34e61588e1b0cb1 SHA512 e78ce86d3265b8c5d1d9b110075bdc8e3ff180a0a017142f852b022a1984e7e9bf0a4b7d2fb829f8c87b09899ef57a6e8ee203ec7edac52e7d05f0a05d2c9fe8
+DIST wxmaxima-22.09.0.tar.gz 21883782 BLAKE2B 370ea04f5101516fda494c08e21c1550556ff69e61e0458814aeb0922c66ae1b4a1be1e0b4d386f631b0479300fec04481f7f9e4be4214689b9bc0b9bd41f0f1 SHA512 778d3f221315f40f09918baaf26a4213dae3154ea19479c5ebf9254ed6c8036ca68f61472fce1d63e72d6c23787a635237c5f85ebc2975254893e6bec112ac3b
diff --git a/sci-mathematics/wxmaxima/wxmaxima-22.09.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-22.09.0.ebuild
new file mode 100644
index 000000000000..16bca7a15010
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-22.09.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}