summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-21 11:22:24 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-21 11:22:24 +0100
commitb54a6bbfcd1e58e8d6f803b9ca28bcd1f1d92ce9 (patch)
treee20a8673c4611aa38ec16ce052d908d52bb0b637 /sci-mathematics
parentdev-util/scons: Fix missing os import in Gentoo patch (diff)
downloadgentoo-b54a6bbfcd1e58e8d6f803b9ca28bcd1f1d92ce9.tar.gz
gentoo-b54a6bbfcd1e58e8d6f803b9ca28bcd1f1d92ce9.tar.bz2
gentoo-b54a6bbfcd1e58e8d6f803b9ca28bcd1f1d92ce9.zip
sci-mathematics/z3: Bump to 4.8.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/z3/Manifest1
-rw-r--r--sci-mathematics/z3/z3-4.8.10.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index 3bafcf281e4f..12e8f9d783c8 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1 +1,2 @@
+DIST z3-4.8.10.tar.gz 4731869 BLAKE2B 92487f71a0c8d961949dc23032d8fa3ff157fe7acc29b41d0d79326f8b59c60e19f43527cccf4e51872c0f0664598f9063876b04cc581f918aa48c37a13c4f3f SHA512 d2741d7ad3e1d5ee3fec92095b061a96a700c3327b2eb2090d4162bdcaeaebca8c072ef79c5daac1f6de3456165c2cc38e13f1045bc707779d1027b943837c5b
DIST z3-4.8.9.tar.gz 4624159 BLAKE2B ff97a688ef3f977cd1204ddafaf6b4ef5824fc8f9f38f0ce9a31657b99b8cb08ee5834893ac67056eb4d7f7df67585933029292eed41d140a93c10b9daa8e100 SHA512 a50da5c3f9e27d3e804c1b71f648a3dbd5a55223b7344d66f191a1b34a4d787810abd976840d3ab3878aaf5c96d89f5a517cac0781b82aa927a9d8d54836d54f
diff --git a/sci-mathematics/z3/z3-4.8.10.ebuild b/sci-mathematics/z3/z3-4.8.10.ebuild
new file mode 100644
index 000000000000..6ffa59ba2b62
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.8.10.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake-multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[cxx,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.8 )"
+BDEPEND="
+ doc? ( app-doc/doxygen )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DZ3_USE_LIB_GMP=$(usex gmp)
+ -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+ -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+ -DZ3_INCLUDE_GIT_HASH=OFF
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md RELEASE_NOTES
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}