summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-05 13:20:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-05 18:53:21 +0200
commitb953b436445abffd13d9320514039055fe4eba04 (patch)
tree1a7fb23cf837d389ab6a799ffe8c8ff8b3a73439 /sci-mathematics
parentsys-devel/clang-runtime: Stabilize 11.1.0 arm64, #777282 (diff)
downloadgentoo-b953b436445abffd13d9320514039055fe4eba04.tar.gz
gentoo-b953b436445abffd13d9320514039055fe4eba04.tar.bz2
gentoo-b953b436445abffd13d9320514039055fe4eba04.zip
sci-mathematics/cvc4: python3_9, switch to cmake.eclass
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cvc4/cvc4-1.7-r1.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild b/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
index e50bae6113f6..36e9f4689a67 100644
--- a/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
+++ b/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
@@ -3,12 +3,12 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+CMAKE_MAKEFILE_GENERATOR=emake
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit cmake python-any-r1
-inherit python-any-r1 cmake-utils
-
-DESCRIPTION="automatic theorem prover for satisfiability modulo theories (SMT) problems"
-HOMEPAGE="http://cvc4.cs.stanford.edu/web/"
+DESCRIPTION="Automatic theorem prover for satisfiability modulo theories (SMT) problems"
+HOMEPAGE="https://cvc4.github.io/"
SRC_URI="https://github.com/CVC4/CVC4/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
@@ -25,12 +25,11 @@ RDEPEND="dev-libs/antlr-c
DEPEND="${RDEPEND}"
BDEPEND="${PYTHON_DEPS}"
-S="${WORKDIR}"/CVC4-${PV}
+S="${WORKDIR}"/${P^^}
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_configure() {
- CMAKE_MAKEFILE_GENERATOR=emake
local mycmakeargs=(
-DANTLR_BINARY=/usr/bin/antlr3
-DENABLE_GPL=ON
@@ -41,7 +40,7 @@ src_configure() {
-DENABLE_PROOFS="$(usex proofs ON OFF)"
-DENABLE_REPLAY="$(usex replay ON OFF)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
@@ -54,10 +53,10 @@ src_test() {
smt2_compliance \
two_smt_engines \
statistics
- cmake-utils_src_test
+ cmake_src_test
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
mv "${D}"/usr/{lib,$(get_libdir)}
}