summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-07-10 22:07:39 -0600
committerChristoph Junghans <junghans@gentoo.org>2017-07-10 22:07:55 -0600
commitbb14cf9a8b120a20a2874241b08650920991dabf (patch)
treec13f235e4c97fefb78970559d14859d9340e0faf /sci-mathematics
parentsys-cluster/ceph: Remove live ebuild since it no longer works (diff)
downloadgentoo-bb14cf9a8b120a20a2874241b08650920991dabf.tar.gz
gentoo-bb14cf9a8b120a20a2874241b08650920991dabf.tar.bz2
gentoo-bb14cf9a8b120a20a2874241b08650920991dabf.zip
sci-mathematics/nauty: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/nauty/Manifest3
-rw-r--r--sci-mathematics/nauty/nauty-2.6.7.ebuild48
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-mathematics/nauty/Manifest b/sci-mathematics/nauty/Manifest
index 1f5fc45f695f..d5e096a3fe35 100644
--- a/sci-mathematics/nauty/Manifest
+++ b/sci-mathematics/nauty/Manifest
@@ -1 +1,4 @@
+DIST nauty-popcnt.patch 56034 SHA256 0dc2e0374491dddf5757f0717d0ea3f949f85b540202385662f10c358b4a08e8 SHA512 4931440b6178cb668997539ac2991f0d04758b8750668d4477cb8a456640640c5bb71c2858e423a4ad812e3401151834366e04693bf9a5ecc5ccc211d2e4229c WHIRLPOOL 5ca13e3295922ccf34ef2e8563bc24e941c401d709ab7f84c6846bfb23440eca4b1c323734b2157fc54dcc859883bcf282140819a51ef7f3da8399913daa821d
DIST nauty25r9.tar.gz 1007323 SHA256 602d0e2e5ab1bdc84ab69f75ebc065833501bd2875cb07b1bb4274e3dd632825 SHA512 79f9054f1d39406063f4cbab61002b27f260b93fd37d6346efdfcd113c59ebab54320e6e7b6cdf26c7eddc376e4ad558e2cd4e6071d418dce2a6918f3c8f7ca2 WHIRLPOOL 0dcce5a74ac5874c5a510cd0d302b5d73897ee3cfaa208945de464e057a4b0af2ba4e717e8d331c51d5065d45363a339e0cd746a0a8fda179ec616b1443e2f63
+DIST nauty26r7.tar.gz 1660659 SHA256 97b5648de17645895cbd56a9a0b3e23cf01f5332c476d013ea459f1a0363cdc6 SHA512 60a724264b43b48338c17240c3cf7156f408267f1b2df995ea7b5ab9fa48852cb11057e83178a364ca028d80dc9124ca9b38cdac34e150a995475140d07c8af6 WHIRLPOOL 16874b8f6874d64a1bff4d2b4f856cc9156dd182b75fe4a3e60754e4bbbd5484733242301ec9763c2c3948b081e1ba0a9271b06226da71f1fc97009c973f2b72
+DIST nauty_2.6r7+ds-1.debian.tar.xz 30328 SHA256 3197d57f3f1b9afe494c9bda07270d9d9aecd5ef213eada77cfaeadfc80c1969 SHA512 fadde6a767e43048980842415207613ffeaa38d021fbf6a3f26a4bbe6877a92ddf5950094de517edd0f924deeacc8dec1d6a7334123c2a87d15befcc3876bc63 WHIRLPOOL 8b17bd77af54b77f089dd495974df965cb6c163106b0686601433b6f264fc33e601454222b520ad0c9e267a28ac8b1b94be28347fd67cece315f98827628ddaa
diff --git a/sci-mathematics/nauty/nauty-2.6.7.ebuild b/sci-mathematics/nauty/nauty-2.6.7.ebuild
new file mode 100644
index 000000000000..2e01267a151a
--- /dev/null
+++ b/sci-mathematics/nauty/nauty-2.6.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools versionator
+
+MY_PV1=$(replace_version_separator 2 'r')
+MY_PV=$(delete_version_separator 1 ${MY_PV1})
+
+DESCRIPTION="Computing automorphism groups of graphs and digraphs"
+HOMEPAGE="http://pallini.di.uniroma1.it/"
+DEBIAN_PATCH_VERSION="1"
+SRC_URI="http://cs.anu.edu.au/~bdm/${PN}/${PN}${MY_PV}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV1}+ds-${DEBIAN_PATCH_VERSION}.debian.tar.xz
+ http://pkgs.fedoraproject.org/cgit/rpms/nauty.git/plain/nauty-popcnt.patch"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+DEPEND="dev-libs/gmp:0
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${MY_PV}"
+DOCS=( schreier.txt config.txt formats.txt changes24-26.txt )
+PATCHES=(
+ "${WORKDIR}"/debian/patches/upstream-lintian-spelling-error.patch
+ "${WORKDIR}"/debian/patches/upstream-fix-gt_numorbits.patch
+ "${WORKDIR}"/debian/patches/upstream-fix-include-extern.patch
+ "${WORKDIR}"/debian/patches/upstream-zlib-blisstog_c.patch
+ "${WORKDIR}"/debian/patches/upstream-C2help2man.patch
+ "${WORKDIR}"/debian/patches/upstream-autotoolization.patch
+ "${WORKDIR}"/debian/patches/system-preprocessing-examples.patch
+ "${DISTDIR}"/nauty-popcnt.patch
+)
+
+src_prepare() {
+ default
+ rm -f makefile
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static --enable-runtime-popcnt --enable-tls
+}