summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-12-07 19:22:05 +0700
committerAndrey Grozin <grozin@gentoo.org>2019-12-07 19:22:05 +0700
commitd29642e477b6d28f3c19c19cf14e3d51e9f068fe (patch)
tree70026e51bee42a394803399b2665212284463e48 /sci-mathematics
parentmedia-gfx/asymptote: cleaning old versions (diff)
downloadgentoo-d29642e477b6d28f3c19c19cf14e3d51e9f068fe.tar.gz
gentoo-d29642e477b6d28f3c19c19cf14e3d51e9f068fe.tar.bz2
gentoo-d29642e477b6d28f3c19c19cf14e3d51e9f068fe.zip
sci-mathematics/wxmaxima: bump to 19.12.1
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-19.12.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 2cb688bd17f4..e269d1c35994 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -4,3 +4,4 @@ DIST wxmaxima-19.08.1.tar.gz 15153254 BLAKE2B 1bd48735ab95b078b9f35d7be623c1a16d
DIST wxmaxima-19.09.0.tar.gz 15153282 BLAKE2B 96cb2db8938b73fb2dc3547310109df581a780a0372687aed9957cd3434fcbec8fef23467543f854f7e6b2c302dba6f3d5a411b17ab83e886175a62dc3fac385 SHA512 fad35fa118e49834d2ff6d54fb1f7cb8675ca1caadbb43c526b7a313479412c1a6c69959a0820c17af0119fc926f66c31368598c9e212fac56305a96d7a39838
DIST wxmaxima-19.10.0.tar.gz 16573758 BLAKE2B 9bee3f8822e9c9ed28058496f7c5c6b2358feeafad39d08d92f3e6ff382817a8a7fd3e33b821f6faba3863f4c8871bc3bebee2b9d97ec6ccfdbfd7c0f7d44940 SHA512 39681cefb81a3816b7daeef7df5b23f57f3a4572ff34396fd447829ceaf6505d09f730255d3c44dd48232879b9994f26a9f86801fe333e15483026d864efdf14
DIST wxmaxima-19.11.0.tar.gz 15304346 BLAKE2B 3a8038f4b67cee261d261f64671227963f91b55969b922282c3b2057029617a5989dc44dc8c28ab17a74e57c2547381dab98b07bf2a1f2f01a5d3c838d6d8a68 SHA512 bb0701ad2be71463ab412649164b2040e5fe95bd6fadb5332fbe5712dc4b65ef30fc86f2ff375e14f1879156fd77e1b8431f15794a136d7e6ee4e6a9393b903a
+DIST wxmaxima-19.12.1.tar.gz 15303584 BLAKE2B 0d7d1fb738563ba0d5805ddc746fc88548c76f249d6c79217f558b7a29c497cf4865810c4aa52f5787e9f4b87aacc93a6ce05726c3bc423c74f382b572ced12d SHA512 74bb60223fb47528f08ed737709eb703d533c27fadfd87deece08f6ec2a6ef1caa489f7ad31f0204010b1b421ab992b4167be133c69bca1b56872685ec0b2cad
diff --git a/sci-mathematics/wxmaxima/wxmaxima-19.12.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-19.12.1.ebuild
new file mode 100644
index 000000000000..b22b9bbbbd26
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-19.12.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+WX_GTK_VER="3.0"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake-utils wxwidgets l10n xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake-utils_src_prepare
+
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm "${S}"/locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f "${S}"/locales/manual/${1}.po
+ rm -f "${S}"/locales/wxwin/${1}.po
+ rm -f "${S}"/info/${PN}.${1}.md
+ rm -f "${S}"/info/${PN}.${1}.html
+ }
+ l10n_find_plocales_changes "${S}"/locales/wxMaxima '' '.po'
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/wxmaxima.hhp /usr/share/doc/${PF}/wxmaxima_tr.hhp
+ cmake-utils_src_install
+}