summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-04 20:37:21 -0500
committerSam James <sam@gentoo.org>2024-03-05 04:47:50 +0000
commitdbda7d259111a90728d62fc56e6d664d5a745f0e (patch)
treeb078339aac9c201fdb4c020b7f62c2c76c57736b /sci-mathematics
parentdev-db/libiodbc: mark as LTO-unsafe (diff)
downloadgentoo-dbda7d259111a90728d62fc56e6d664d5a745f0e.tar.gz
gentoo-dbda7d259111a90728d62fc56e6d664d5a745f0e.tar.bz2
gentoo-dbda7d259111a90728d62fc56e6d664d5a745f0e.zip
sci-mathematics/glpk: mark as LTO-unsafe, strict-aliasing unsafe
It has been reported upstream but no response. Closes: https://bugs.gentoo.org/863047 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/glpk/glpk-5.0-r1.ebuild11
-rw-r--r--sci-mathematics/glpk/glpk-5.0-r2.ebuild9
2 files changed, 19 insertions, 1 deletions
diff --git a/sci-mathematics/glpk/glpk-5.0-r1.ebuild b/sci-mathematics/glpk/glpk-5.0-r1.ebuild
index 4035b2d2c2a9..cdfbef93af93 100644
--- a/sci-mathematics/glpk/glpk-5.0-r1.ebuild
+++ b/sci-mathematics/glpk/glpk-5.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,6 +49,15 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/863047
+ # https://lists.gnu.org/archive/html/bug-glpk/2022-08/msg00000.html
+ # No upstream response...
+ #
+ # Do not trust it to LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local myconf
if use mysql || use odbc; then
myconf="--enable-dl"
diff --git a/sci-mathematics/glpk/glpk-5.0-r2.ebuild b/sci-mathematics/glpk/glpk-5.0-r2.ebuild
index ccc0e863233f..af7007591862 100644
--- a/sci-mathematics/glpk/glpk-5.0-r2.ebuild
+++ b/sci-mathematics/glpk/glpk-5.0-r2.ebuild
@@ -53,6 +53,15 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/863047
+ # https://lists.gnu.org/archive/html/bug-glpk/2022-08/msg00000.html
+ # No upstream response...
+ #
+ # Do not trust it to LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local myconf
if use mysql || use odbc; then
myconf="--enable-dl"