summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-21 14:26:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-21 14:28:17 +0200
commite0cecc84ef03cbd65782dfee4f5caec81ced0f1e (patch)
treeb2f7c53d1d96761e29ecfc9e0b9fe84b16709b25 /sci-mathematics
parentdev-util/checkbashisms: Bump to version 2.19.7 (diff)
downloadgentoo-e0cecc84ef03cbd65782dfee4f5caec81ced0f1e.tar.gz
gentoo-e0cecc84ef03cbd65782dfee4f5caec81ced0f1e.tar.bz2
gentoo-e0cecc84ef03cbd65782dfee4f5caec81ced0f1e.zip
sci-mathematics/rkward: Fix build with Qt 5.13 (?)
Reported-by: Helmut Jarausch <jarausch@igpm.rwth-aachen.de> Closes: https://bugs.gentoo.org/698198 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-1.patch23
-rw-r--r--sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-2.patch23
-rw-r--r--sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-3.patch33
-rw-r--r--sci-mathematics/rkward/rkward-0.7.0b.ebuild2
4 files changed, 81 insertions, 0 deletions
diff --git a/sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-1.patch b/sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-1.patch
new file mode 100644
index 000000000000..af45406a417c
--- /dev/null
+++ b/sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-1.patch
@@ -0,0 +1,23 @@
+From b51802243f478d1d89120edc343bec7eb5ef8285 Mon Sep 17 00:00:00 2001
+From: Thomas Friedrichsmeier <thomas.friedrichsmeier@ruhr-uni-bochum.de>
+Date: Wed, 24 Jul 2019 19:36:51 +0200
+Subject: Fix compilation
+
+---
+ rkward/windows/rkworkplace.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/rkward/windows/rkworkplace.cpp b/rkward/windows/rkworkplace.cpp
+index 0dbf36a..94b3378 100644
+--- a/rkward/windows/rkworkplace.cpp
++++ b/rkward/windows/rkworkplace.cpp
+@@ -31,6 +31,7 @@
+ #include <QDir>
+ #include <QApplication>
+ #include <QMimeDatabase>
++#include <QLayout>
+
+ #include "detachedwindowcontainer.h"
+ #include "rkcommandeditorwindow.h"
+--
+cgit v1.1
diff --git a/sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-2.patch b/sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-2.patch
new file mode 100644
index 000000000000..bbb07c1e8fca
--- /dev/null
+++ b/sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-2.patch
@@ -0,0 +1,23 @@
+From d713ce77e077b426d9d81a22f558f71dfa832615 Mon Sep 17 00:00:00 2001
+From: Thomas Friedrichsmeier <thomas.friedrichsmeier@ruhr-uni-bochum.de>
+Date: Fri, 26 Jul 2019 22:32:42 +0200
+Subject: Another missing include file
+
+---
+ rkward/windows/rktoolwindowbar.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/rkward/windows/rktoolwindowbar.cpp b/rkward/windows/rktoolwindowbar.cpp
+index a8f5cbd..03c405e 100644
+--- a/rkward/windows/rktoolwindowbar.cpp
++++ b/rkward/windows/rktoolwindowbar.cpp
+@@ -27,6 +27,7 @@
+
+ #include <QSplitter>
+ #include <QContextMenuEvent>
++#include <QHBoxLayout>
+
+ #include "rkworkplace.h"
+ #include "rkworkplaceview.h"
+--
+cgit v1.1
diff --git a/sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-3.patch b/sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-3.patch
new file mode 100644
index 000000000000..e907f2877cec
--- /dev/null
+++ b/sci-mathematics/rkward/files/rkward-0.7.0b-qt-5.13-3.patch
@@ -0,0 +1,33 @@
+From 394128e8d58b58bbd7cef9a4523ae346f94cd456 Mon Sep 17 00:00:00 2001
+From: Thomas Friedrichsmeier <thomas.friedrichsmeier@ruhr-uni-bochum.de>
+Date: Sat, 27 Jul 2019 11:12:34 +0200
+Subject: Another include file fix
+
+---
+ rkward/rkward.cpp | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/rkward/rkward.cpp b/rkward/rkward.cpp
+index 1a4a7e3..bb2f69c 100644
+--- a/rkward/rkward.cpp
++++ b/rkward/rkward.cpp
+@@ -26,6 +26,9 @@
+ #include <QMenuBar>
+ #include <QStatusBar>
+ #include <QInputDialog>
++#include <QVBoxLayout>
++#include <QHBoxLayout>
++#include <QIcon>
+
+ // include files for KDE
+ #include <kmessagebox.h>
+@@ -41,7 +44,6 @@
+ #include <krecentfilesaction.h>
+ #include <ktoolbar.h>
+ #include <kactionmenu.h>
+-#include <QIcon>
+ #include <KSharedConfig>
+ #include <KConfigGroup>
+
+--
+cgit v1.1
diff --git a/sci-mathematics/rkward/rkward-0.7.0b.ebuild b/sci-mathematics/rkward/rkward-0.7.0b.ebuild
index 4c651729fa1d..ea892c6968ac 100644
--- a/sci-mathematics/rkward/rkward-0.7.0b.ebuild
+++ b/sci-mathematics/rkward/rkward-0.7.0b.ebuild
@@ -48,3 +48,5 @@ RDEPEND="${DEPEND}
virtual/libintl
!sci-mathematics/rkward:4
"
+
+PATCHES=( "${FILESDIR}"/${P}-qt-5.13-{1,2,3}.patch)