summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-14 20:51:09 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-14 21:27:58 +0100
commitea3d2b7f343f78b5684f0d88116de481de6bd428 (patch)
tree7716c0f2571135cdaf9bcfe6c7a2a866fcf966e5 /sci-mathematics
parentsci-mathematics/cryptominisat: drop old 5.11.14 (diff)
downloadgentoo-ea3d2b7f343f78b5684f0d88116de481de6bd428.tar.gz
gentoo-ea3d2b7f343f78b5684f0d88116de481de6bd428.tar.bz2
gentoo-ea3d2b7f343f78b5684f0d88116de481de6bd428.zip
sci-mathematics/cryptominisat: bump to 5.11.21
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cryptominisat/Manifest1
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
index d56bf9cb9c63..ece5315dfb22 100644
--- a/sci-mathematics/cryptominisat/Manifest
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -1 +1,2 @@
DIST cryptominisat-5.11.15.tar.gz 968163 BLAKE2B e14d7d42fa8391cbb16d887c90b3a4d272644895ec11cf134df8b9d8e46ef425afab3622cf109d4c1f2a16f6f24d3768110aff947df0070cd660b29da1cdc609 SHA512 a84e060e3fddbd19f1b35f61b0931c342cdb545d1135f33b5390446598b8d5743258e59975b71d62a25b86e0704d90b52072e97989f1b81e80e2bbba3118d3fb
+DIST cryptominisat-5.11.21.tar.gz 975459 BLAKE2B c1a8e274a5221584c7245405f6b617951528a477ae36680da293acc9e7ee46692a0a37c057749a98c41b7bc302a3d0b9de176379b8c9aece339c2aaa6b6a3308 SHA512 5a1ac51b27cc692c793831aba83cc71188f9c46abdef809fae9c830a2801e1c45310cf5ada1ba4e10cb11aba5efef6407a9f7f0506474f30bdd4a58bfcbdbef7
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
new file mode 100644
index 000000000000..4beb16299f8c
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and command-line interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/msoos/${PN}.git"
+else
+ SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 MIT"
+SLOT="0/${PV}"
+RESTRICT="test" # Tests require some git modules.
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOBREAKID=ON
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}