summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-01-04 12:40:06 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-01-04 12:40:06 +0700
commitf1326b54f5731cffeb92260c68ec9602f7fa6daa (patch)
tree0c0909cf6b5edb006c35d2812ad0cecd44b13fbc /sci-mathematics
parentapp-shells/bash: crank copyright (diff)
downloadgentoo-f1326b54f5731cffeb92260c68ec9602f7fa6daa.tar.gz
gentoo-f1326b54f5731cffeb92260c68ec9602f7fa6daa.tar.bz2
gentoo-f1326b54f5731cffeb92260c68ec9602f7fa6daa.zip
sci-mathematics/wxmaxima: bump to 22.12.0
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-22.12.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 9c03fdb4320c..cfc7f09b5711 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxmaxima-20.12.2.tar.gz 16262617 BLAKE2B 2f9f910f565158b2011f014d96747498c6286a95bdb69f9b6b2f82a37a569e8a02abbae5cbb9ae2ac1e78d0b976487666794b267c1c40c1245df08c752486403 SHA512 1c3e3f68a2fa2cd798dfb05c52e7ddf3193a15cb45282553c280914bd524d463ad27acc89898cb4a292ff236699d1ec2abb70d83fa52cb126123ab8e2fcd5ceb
DIST wxmaxima-22.05.0.tar.gz 21493488 BLAKE2B 0b1f4bd65e88e4f39d5d54f164373ca67a76bd2a18a1556cd4b86cdb5a62ca3f0c783c6e1725ec1006f6174163f08b7b934dcfa3fd8a8a7aa34e61588e1b0cb1 SHA512 e78ce86d3265b8c5d1d9b110075bdc8e3ff180a0a017142f852b022a1984e7e9bf0a4b7d2fb829f8c87b09899ef57a6e8ee203ec7edac52e7d05f0a05d2c9fe8
DIST wxmaxima-22.09.0.tar.gz 21883782 BLAKE2B 370ea04f5101516fda494c08e21c1550556ff69e61e0458814aeb0922c66ae1b4a1be1e0b4d386f631b0479300fec04481f7f9e4be4214689b9bc0b9bd41f0f1 SHA512 778d3f221315f40f09918baaf26a4213dae3154ea19479c5ebf9254ed6c8036ca68f61472fce1d63e72d6c23787a635237c5f85ebc2975254893e6bec112ac3b
+DIST wxmaxima-22.12.0.tar.gz 23673254 BLAKE2B b00536c6b6243555f4c00016202d68f9764a2e1ec4c910ee52d7e0b498a5695c3f4746809e594179cda75ec40caeca1a01e21a11c211c329ec2685a8e6217e4e SHA512 842a4c891d757d17307a9bed17f5ffffde9f55e72b749e2356817a1598760b6a16fb9ce8e21f4706530bbe2360400de01b9269872d895944924d8e3eebfc31dc
diff --git a/sci-mathematics/wxmaxima/wxmaxima-22.12.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-22.12.0.ebuild
new file mode 100644
index 000000000000..552ce4da0c45
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-22.12.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}