summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-25 17:31:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-25 18:07:47 +0200
commitf31e51402a27f7591f4b5ff461d0c0eaadf66f40 (patch)
tree65823915a40aaaffb7dfe3baab1ad6635801db56 /sci-mathematics
parentdev-lang/ammonite-repl-bin: drop 2.5.5, 2.5.6 (diff)
downloadgentoo-f31e51402a27f7591f4b5ff461d0c0eaadf66f40.tar.gz
gentoo-f31e51402a27f7591f4b5ff461d0c0eaadf66f40.tar.bz2
gentoo-f31e51402a27f7591f4b5ff461d0c0eaadf66f40.zip
sci-mathematics/cryptominisat: bump to 5.11.11
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cryptominisat/Manifest1
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
index eebe71f07e88..97b6a41c7268 100644
--- a/sci-mathematics/cryptominisat/Manifest
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -1 +1,2 @@
+DIST cryptominisat-5.11.11.tar.gz 1012869 BLAKE2B 768ae936380c05f3129ac642fe8e7c3581824f8be8e02c7d6709fbb8ca1e43eae04ba6d16d441063ed4cbe597a64ee357fa8b45e3f740a6cf11c00f9225b6b5d SHA512 21827627a1765b760df4635f3606ba83c76bac52217120a0b4c97bcb05526fe6cf7325dff04385525f763f20a0371586dc929eb3c57023b3367a8af9ea8e947a
DIST cryptominisat-5.11.4.tar.gz 1044845 BLAKE2B b6df4e61c5f37d24a61a5c782f08f223c413e19fc2b1625718f7d19d4df8f4d955a92ae447f6c98889927ddc7407b4790092086996a0a32879c7dcb614ca1024 SHA512 8593848c468a6b1ac3d9ae343384aa323fb6ddc17802c9b184c178b9a41314c463b1c5f02ffd19d6e844894c7998e41d6e9b808ed70dcc235aa595607f52bc76
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild
new file mode 100644
index 000000000000..4d4e2a5c0742
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and command-line interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/msoos/${PN}.git"
+else
+ SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="0/${PV}"
+LICENSE="GPL-2 MIT"
+RESTRICT="test" # Tests require many git modules.
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOBREAKID=ON
+ -DNOM4RI=ON
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}