summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-13 21:19:37 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-13 21:26:09 +0200
commitf5770fff2fb5fbbf1858672ddce3533c4ea4df6c (patch)
treef041ea6a90ad0bc079c8063bd99187cbc2357a39 /sci-mathematics
parentapp-emulation/uxn: remove unused patch (diff)
downloadgentoo-f5770fff2fb5fbbf1858672ddce3533c4ea4df6c.tar.gz
gentoo-f5770fff2fb5fbbf1858672ddce3533c4ea4df6c.tar.bz2
gentoo-f5770fff2fb5fbbf1858672ddce3533c4ea4df6c.zip
sci-mathematics/verifpal: new package; add 0.27.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/verifpal/Manifest2
-rw-r--r--sci-mathematics/verifpal/files/verifpal-0.27.0-no-external-generate.patch13
-rw-r--r--sci-mathematics/verifpal/metadata.xml16
-rw-r--r--sci-mathematics/verifpal/verifpal-0.27.0.ebuild39
4 files changed, 70 insertions, 0 deletions
diff --git a/sci-mathematics/verifpal/Manifest b/sci-mathematics/verifpal/Manifest
new file mode 100644
index 000000000000..035cca097f6f
--- /dev/null
+++ b/sci-mathematics/verifpal/Manifest
@@ -0,0 +1,2 @@
+DIST verifpal-0.27.0-deps.tar.xz 11658240 BLAKE2B 6d4f433311177874acbe4df1367c82ea2c69d5d54708384e1bd6f341bb8b5546629cd2b9f822381cbdcd0bd25f63f77f426c44a1337f69cd813869f16bfbd8dd SHA512 397a7ebf68110f69c90d02aabc3c05d3f169b29d40fc5aca7b6c697b7179bb033d783e7b369c60714facb8dc83908c503bcefe938d2e9af95a75a334f23220e5
+DIST verifpal-v0.27.0.tar.bz2 251067 BLAKE2B 25b0f03366555c98928f2cadd3fcc21c3bd5539ea9bd31e66b0868f5be48ac7b664538535b59ce44305f024a7f192e7c4caf1c15054d269995ffff2704d22429 SHA512 f350e362d892ac5179224be102fd7537b19d9eb571b5ff4c84a673e7f996b2741ed965a23aaa249ca9e33c68f24ee7541b31e52cd5fe5990f4ca1e9283f8930b
diff --git a/sci-mathematics/verifpal/files/verifpal-0.27.0-no-external-generate.patch b/sci-mathematics/verifpal/files/verifpal-0.27.0-no-external-generate.patch
new file mode 100644
index 000000000000..7286b81359f3
--- /dev/null
+++ b/sci-mathematics/verifpal/files/verifpal-0.27.0-no-external-generate.patch
@@ -0,0 +1,13 @@
+--- a/cmd/verifpal/main.go
++++ b/cmd/verifpal/main.go
+@@ -3,10 +3,8 @@
+ // 8e05848fe7fc3fb8ed3ba50a825c5493
+
+ //go:generate go run ../../internal/libcoq/libcoqgen.go
+-//go:generate pigeon -o ../../cmd/vplogic/libpeg.go ../../internal/libpeg/libpeg.peg
+ //go:generate gofmt -s -w ../../cmd/vplogic/libcoq.go
+ //go:generate gofmt -s -w ../../cmd/vplogic/libpeg.go
+-//go:generate goversioninfo -64=true -icon=../../assets/icon.ico ../../assets/versioninfo.json
+
+ package main
+
diff --git a/sci-mathematics/verifpal/metadata.xml b/sci-mathematics/verifpal/metadata.xml
new file mode 100644
index 000000000000..53f63e5b4c26
--- /dev/null
+++ b/sci-mathematics/verifpal/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Verifpal is new software for verifying the security of cryptographic
+ protocols. Building upon contemporary research in symbolic formal
+ verification, Verifpal’s main aim is to appeal more to real-world
+ practitioners, students and engineers without sacrificing comprehensive
+ formal verification features.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/verifpal/verifpal-0.27.0.ebuild b/sci-mathematics/verifpal/verifpal-0.27.0.ebuild
new file mode 100644
index 000000000000..444b9284c857
--- /dev/null
+++ b/sci-mathematics/verifpal/verifpal-0.27.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Cryptographic protocol analysis for real-world protocols"
+HOMEPAGE="https://verifpal.com/
+ https://source.symbolic.software/verifpal/verifpal/"
+SRC_URI="
+ https://source.symbolic.software/${PN}/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.27.0-no-external-generate.patch )
+
+DOCS=( README.md examples )
+
+src_compile() {
+ local -a go_buildargs=(
+ -trimpath
+ -gcflags="-e"
+ -ldflags="-s -w"
+ )
+ ego build "${go_buildargs[@]}" ./cmd/verifpal
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe "${PN}"
+
+ einstalldocs
+}