summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-06-02 12:24:31 +0700
committerAndrey Grozin <grozin@gentoo.org>2019-06-02 12:24:31 +0700
commitf987abf4a3928e6b49f13401a17b429eeea09da9 (patch)
tree95dee339d749a4b330c236071ec52639a3026e59 /sci-mathematics
parentdev-java/icedtea-bin: add arm 3.12 tarball (diff)
downloadgentoo-f987abf4a3928e6b49f13401a17b429eeea09da9.tar.gz
gentoo-f987abf4a3928e6b49f13401a17b429eeea09da9.tar.bz2
gentoo-f987abf4a3928e6b49f13401a17b429eeea09da9.zip
sci-mathematics/arb: bump to 2.16.0
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/arb/Manifest1
-rw-r--r--sci-mathematics/arb/arb-2.16.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-mathematics/arb/Manifest b/sci-mathematics/arb/Manifest
index bf918a7f9de6..a8ef8a032e96 100644
--- a/sci-mathematics/arb/Manifest
+++ b/sci-mathematics/arb/Manifest
@@ -1 +1,2 @@
DIST arb-2.11.1.tar.gz 1248835 BLAKE2B 8ba11f3a92103231c4710c0158ce0811b2a01872e1ec7b7a4a4320d27ab86688aa8733df6dd2464aa55c0a506a8a595e4c370848c78b5c3a650e647f0c6d7411 SHA512 7a014da5208b55f20c7a3cd3eb51070b09ae107b04cbbd6329925780c2ab4d7c38e1fb3619f21456fa806939818370fcae921f59eb013661b6bdd3d0971e3353
+DIST arb-2.16.0.tar.gz 1526059 BLAKE2B 14f4a9b23fa6fc46659b742cc95b4970cee74cf52bda8bc696831b0a5c1f946f41f1c2bba180ad1199c55d741366b3376aeed0efbf6ee087b26f6de788519739 SHA512 171c965aeb03cd2830df8a53990403c6da480a94d44385dadfbb2d02697f7c03e8b9a217094b0ad93f796d889a1564f4b9ae9db35ef9de90f61bb2e3220911be
diff --git a/sci-mathematics/arb/arb-2.16.0.ebuild b/sci-mathematics/arb/arb-2.16.0.ebuild
new file mode 100644
index 000000000000..72f391958855
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.16.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="http://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ >=sci-mathematics/flint-2.5.0:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Not an autoconf configure script.
+ # Note that it appears to have been cloned from the flint configure script
+ # and that not all the options offered are valid.
+ tc-export CC AR CXX
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --with-flint="${EPREFIX}/usr" \
+ --with-gmp="${EPREFIX}/usr" \
+ --with-mpfr="${EPREFIX}/usr" \
+ $(use_enable static-libs static) \
+ CFLAGS="${CPPFLAGS} ${CFLAGS}" || die
+}
+
+src_compile() {
+ emake verbose
+}
+
+src_test() {
+ # Have to set the library path otherwise a previous install of libarb may be loaded.
+ # This is in part a consequence of setting the soname/installnae I think.
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ DYLD_LIBRARY_PATH="${S}" emake AT= QUIET_CC= QUIET_CXX= QUIET_AR= check
+ else
+ LD_LIBRARY_PATH="${S}" emake AT= QUIET_CC= QUIET_CXX= QUIET_AR= check
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
+ use static-libs || prune_libtool_files --all
+ dodoc README.md
+}