summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-15 09:31:04 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-15 09:41:12 +0100
commitff43595f6fc27b3ffca106f140c5e677f7c38418 (patch)
treeec28660d4ce17210b606d64be510513712b56f4d /sci-mathematics
parentsci-mathematics/lean: drop old 3.48.0 (diff)
downloadgentoo-ff43595f6fc27b3ffca106f140c5e677f7c38418.tar.gz
gentoo-ff43595f6fc27b3ffca106f140c5e677f7c38418.tar.bz2
gentoo-ff43595f6fc27b3ffca106f140c5e677f7c38418.zip
sci-mathematics/lean: bump to 3.50.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/lean/Manifest1
-rw-r--r--sci-mathematics/lean/lean-3.50.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sci-mathematics/lean/Manifest b/sci-mathematics/lean/Manifest
index a6322520da8d..334759fa7784 100644
--- a/sci-mathematics/lean/Manifest
+++ b/sci-mathematics/lean/Manifest
@@ -1,2 +1,3 @@
DIST lean-3.49.0.tar.gz 1918154 BLAKE2B 9f9973d00d2d5d5b7d26d50117c27754feb5132e88decd55859432a384dac2897184dcf8d841ad0034854657ac25e462dc69cdbe1cf2040787d108bb7e1370f4 SHA512 b4672843c2e923da8d56b91c14966fc2ec66c573564d68db9c52f9b40f2c97d82497f2ef6424b023c4ae50f6f0c11674e2d79053844ea669d226d0fe24077ade
DIST lean-3.49.1.tar.gz 1918165 BLAKE2B bebb29023f7d8979dae19d7c5ef6503be03012366c8a4f21a69244a1daadf90c73e8a8754656d7b1a6eccb1123f0905f3dcaa15885b0307399979024d2c5a051 SHA512 6648ab84840099495df5bec9432c75c40fc0920ac2a18297b42c35de593ec4eaee8bcf807cb6e273c2715090e5d1ab6c59652f482016af68d758e7e6e55dd87f
+DIST lean-3.50.0.tar.gz 1918549 BLAKE2B 79827ffb9f825dff040e41e9bcbd8306e2f3a116b74fc6e0831450765d5b896fad2a86ec5dd9e63bf0f8777b575d4ab7ae8d158c233364fad6d4437bc0767452 SHA512 2b8d730ef9d808a24a9708f2b33409510bd6b7350f515679ba0395a45fc2dea2125639cdeb867bec4ac9c8114e448fb9777a69f8859e172f6e694ecacbb07f56
diff --git a/sci-mathematics/lean/lean-3.50.0.ebuild b/sci-mathematics/lean/lean-3.50.0.ebuild
new file mode 100644
index 000000000000..e008b81cf582
--- /dev/null
+++ b/sci-mathematics/lean/lean-3.50.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR=$(ver_cut 1)
+CMAKE_IN_SOURCE_BUILD="ON"
+
+inherit flag-o-matic cmake readme.gentoo-r1
+
+DESCRIPTION="The Lean Theorem Prover"
+HOMEPAGE="https://leanprover-community.github.io/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/lean.git"
+else
+ SRC_URI="https://github.com/leanprover-community/lean/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${S}/src"
+
+LICENSE="Apache-2.0"
+SLOT="0/${MAJOR}"
+IUSE="debug +threads"
+
+RDEPEND="dev-libs/gmp:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-CMakeLists-fix_flags.patch )
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug; then
+ CMAKE_BUILD_TYPE="Debug"
+ else
+ CMAKE_BUILD_TYPE="Release"
+ fi
+
+ filter-lto
+
+ local mycmakeargs=(
+ -DALPHA=ON
+ -DAUTO_THREAD_FINALIZATION=ON
+ -DJSON=ON # bug 833900
+ -DLEAN_EXTRA_CXX_FLAGS="${CXXFLAGS}"
+ -DMULTI_THREAD=$(usex threads)
+ -DUSE_GITHASH=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Disable problematic "style_check" cpplint test,
+ # this also removes the python test dependency
+ --exclude-regex style_check
+ )
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ local DISABLE_AUTOFORMATTING="yes"
+ local DOC_CONTENTS="You probably want to use lean with mathlib, you can either:
+ - Do not install mathlib globally and use local versions
+ - Use leanproject from sci-mathematics/mathlib-tools
+ $ leanproject global-install
+ - Use leanpkg and compile mathlib (which will take some time)
+ $ leanpkg install https://github.com/leanprover-community/mathlib"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}