summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2020-11-08 15:21:41 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-01-18 15:37:24 +0200
commite9b2020e1f608225d8fd30a16b4b7a1dcb9f214f (patch)
treef01a09c6e51b616be4fabd3bd7e97ddb7326d427 /sci-misc/boinc/files
parentacct-user/boinc: User for sci-misc/boinc (diff)
downloadgentoo-e9b2020e1f608225d8fd30a16b4b7a1dcb9f214f.tar.gz
gentoo-e9b2020e1f608225d8fd30a16b4b7a1dcb9f214f.tar.bz2
gentoo-e9b2020e1f608225d8fd30a16b4b7a1dcb9f214f.zip
sci-misc/boinc: V7.16.14 bump, EAPI 7 upgrade, bug fixes, GLEP 81
This version bump also fixes the following issues: * The user/group management is now done according to GLEP 81 * /etc/init.d/boinc: Ensure correct RUNTIMEDIR permissions (#684074) * /etc/init.d/boinc: The password does no longer need to be submitted * Hardcoded library search paths to /lib and /usr/lib have been removed or switched to /lib64 and /usr/lib64, if those are the regular library directories on the emerging system. (#732024) Closes: https://bugs.gentoo.org/684074 Closes: https://bugs.gentoo.org/717580 Closes: https://bugs.gentoo.org/732024 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-misc/boinc/files')
-rw-r--r--sci-misc/boinc/files/boinc-7.16-fix_webview.patch11
-rw-r--r--sci-misc/boinc/files/boinc-7.16-remove-usr_lib.patch89
-rw-r--r--sci-misc/boinc/files/boinc.init.in53
3 files changed, 110 insertions, 43 deletions
diff --git a/sci-misc/boinc/files/boinc-7.16-fix_webview.patch b/sci-misc/boinc/files/boinc-7.16-fix_webview.patch
new file mode 100644
index 000000000000..4f58b2725b31
--- /dev/null
+++ b/sci-misc/boinc/files/boinc-7.16-fix_webview.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2020-11-08 00:31:06.304751639 +0100
++++ b/configure.ac 2020-11-08 00:32:03.848754956 +0100
+@@ -1238,7 +1238,7 @@
+ CLIENTGUIFLAGS="${CLIENTGUIFLAGS} -DNDEBUG"
+ fi
+
+-CLIENTGUILIBS="${WX_LIBS}"
++CLIENTGUILIBS="${WX_LIBS} $($WX_CONFIG_WITH_ARGS --libs webview)"
+
+ if test "${enable_client_release}" = "yes" ; then
+ if test "x${WX_LIBS_STATIC}" = "x" ; then
diff --git a/sci-misc/boinc/files/boinc-7.16-remove-usr_lib.patch b/sci-misc/boinc/files/boinc-7.16-remove-usr_lib.patch
new file mode 100644
index 000000000000..c9750a03b666
--- /dev/null
+++ b/sci-misc/boinc/files/boinc-7.16-remove-usr_lib.patch
@@ -0,0 +1,89 @@
+--- a/m4/ax_check_glut.m4 2020-11-08 01:03:40.797864295 +0100
++++ b/m4/ax_check_glut.m4 2020-11-08 01:04:53.407868481 +0100
+@@ -41,7 +41,7 @@
+ else
+ ax_try_lib="${ax_lib}"
+ fi
+- LIBS="-L${prefix}/lib ${ax_try_lib} ${GLUT_LIBS} ${ax_save_LIBS}"
++ LIBS="${ax_try_lib} ${GLUT_LIBS} ${ax_save_LIBS}"
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[
+ #define FREEGLUT_STATIC 1
+@@ -50,7 +50,7 @@
+ # endif
+ # include <GL/glut.h>]],
+ [[glutMainLoop()]])],
+- [ax_cv_check_glut_libglut="-L${prefix}/lib ${ax_try_lib}"; break])
++ [ax_cv_check_glut_libglut="${ax_try_lib}"; break])
+
+ done
+ LIBS=${ax_save_LIBS}
+--- a/m4/ax_check_glu.m4 2020-11-08 01:03:48.221864723 +0100
++++ b/m4/ax_check_glu.m4 2020-11-08 01:04:53.405868480 +0100
+@@ -19,7 +19,7 @@
+ else
+ ax_try_lib="${ax_lib}"
+ fi
+- LIBS="-L${prefix}/lib ${ax_try_lib} ${GL_LIBS} ${ax_save_LIBS}"
++ LIBS="${ax_try_lib} ${GL_LIBS} ${ax_save_LIBS}"
+ #
+ # libGLU typically links with libstdc++ on POSIX platforms. However,
+ # setting the language to C++ means that test program source is named
+@@ -37,7 +37,7 @@
+ # endif
+ # include <GL/glu.h>]],
+ [[gluBeginCurve(0)]])],
+- [ax_cv_check_glu_libglu="-L${prefix}/lib ${ax_try_lib}"; break])
++ [ax_cv_check_glu_libglu="${ax_try_lib}"; break])
+ if test X$ax_compiler_ms = Xyes; then
+ AC_LANG_POP([C])
+ fi
+--- a/m4/ax_check_gl.m4 2020-11-08 01:03:57.178865240 +0100
++++ b/m4/ax_check_gl.m4 2020-11-08 01:04:53.401868480 +0100
+@@ -39,7 +39,7 @@
+ GL_CFLAGS="-I${x_includes} -I${prefix}/include ${GL_CFLAGS}"
+ fi
+ if test -n "$x_libraries"; then
+- GL_LIBS="-L${x_libraries} -L${prefix}/lib -lX11 ${GL_LIBS}"
++ GL_LIBS="-L${x_libraries} -lX11 ${GL_LIBS}"
+ fi
+ fi
+
+@@ -58,7 +58,7 @@
+ else
+ ax_try_lib="${ax_lib}"
+ fi
+- LIBS="-L${prefix}/lib ${ax_try_lib} ${GL_LIBS} ${ax_save_LIBS}"
++ LIBS="${ax_try_lib} ${GL_LIBS} ${ax_save_LIBS}"
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[
+ # if HAVE_WINDOWS_H && defined(_WIN32)
+@@ -66,7 +66,7 @@
+ # endif
+ # include <GL/gl.h>]],
+ [[glBegin(0)]])],
+- [ax_cv_check_gl_libgl="-L${prefix}/lib ${ax_try_lib}"; break])
++ [ax_cv_check_gl_libgl="${ax_try_lib}"; break])
+ done
+ LIBS=${ax_save_LIBS}
+ CPPFLAGS=${ax_save_CPPFLAGS}])
+--- a/m4/check_ssl.m4 2020-11-11 08:29:37.638655925 +0100
++++ b/m4/check_ssl.m4 2020-11-11 08:31:28.319659865 +0100
+@@ -46,7 +46,7 @@
+ SSLDIR="${ssldir}"
+ SSL_CFLAGS="-I$ssldir/include -I$ssldir/include/openssl";
+ SSL_CXXFLAGS="-I$ssldir/include -I$ssldir/include/openssl";
+- SSL_LIBS="-L$ssldir -L$ssldir/lib -lssl -lcrypto"
++ SSL_LIBS="-lssl -lcrypto"
+ AC_CHECK_LIB([dl], [dlopen],
+ [SSL_LIBS="${SSL_LIBS} ${sah_lib_last}"])
+ AC_CHECK_LIB([z], [gzopen],
+@@ -58,7 +58,7 @@
+ SSLDIR="${ssldir}"
+ SSL_CFLAGS="-I$ssldir/include/"
+ SSL_CXXFLAGS="-I$ssldir/include/"
+- SSL_LIBS="-L$ssldir -L$ssldir/lib -lssl -lcrypto"
++ SSL_LIBS="-lssl -lcrypto"
+ AC_CHECK_LIB([dl], [dlopen],
+ [SSL_LIBS="${SSL_LIBS} ${sah_lib_last}"])
+ AC_CHECK_LIB([z], [gzopen],
diff --git a/sci-misc/boinc/files/boinc.init.in b/sci-misc/boinc/files/boinc.init.in
index b46a06e3d384..763b69694444 100644
--- a/sci-misc/boinc/files/boinc.init.in
+++ b/sci-misc/boinc/files/boinc.init.in
@@ -18,12 +18,12 @@ create_work_directory() {
eerror "Directory ${RUNTIMEDIR} could not be created!"
return 1
fi
+ fi
- # ensure proper ownership
- if ! chown "${USER}:${GROUP}" "${RUNTIMEDIR}"; then
- eerror "Changing ownership of '${RUNTIMEDIR}' to '${USER}:${GROUP}' failed!"
- return 1
- fi
+ # ensure proper ownership
+ if ! chown "${USER}:${GROUP}" "${RUNTIMEDIR}"; then
+ eerror "Changing ownership of '${RUNTIMEDIR}' to '${USER}:${GROUP}' failed!"
+ return 1
fi
if [ ! -e "${RUNTIMEDIR}"/ca-bundle.crt ]; then
@@ -117,17 +117,6 @@ env_check() {
return 0
}
-need_passwd_arg() {
- local vers=$(${BOINCBIN} --version | tr -d .)
- [ -z "${vers}" ] && vers="00"
- [ $(expr substr "${vers}" 1 2) -lt 74 ] && return 0
-
- # From version 7.4 on, the default is to read
- # gui_rpc_auth.cfg for the password.
-
- return 1
-}
-
start_pre() {
env_check || return 1
create_work_directory || return 1
@@ -164,7 +153,6 @@ start() {
}
attach() {
- local password=""
local url=""
local key=""
@@ -182,14 +170,10 @@ attach() {
"${RC_SERVICE}" start
fi
- if need_passwd_arg; then
- password="--passwd \"$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")\""
- fi
-
ebegin "${RC_SVCNAME}: Attaching to project"
start-stop-daemon --user "${USER}:${GROUP}" --quiet \
--chdir "${RUNTIMEDIR}" --exec "${BOINCCMD}" \
- -- ${password} --project_attach ${url} ${key}
+ -- --project_attach ${url} ${key}
eend $?
sleep 10
@@ -197,15 +181,10 @@ attach() {
}
stop() {
- local password=""
local stop_timeout="SIGTERM/60/SIGTERM/30/SIGKILL/30"
env_check || return 1
- if need_passwd_arg; then
- password="--passwd \"$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")\""
- fi
-
ebegin "Stopping ${RC_SVCNAME}"
start-stop-daemon --stop --quiet --progress \
--retry ${stop_timeout} \
@@ -216,19 +195,13 @@ stop() {
resume() {
env_check || return 1
- local password=""
-
- if need_passwd_arg; then
- password="--passwd \"$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")\""
- fi
-
for url in $(cd "${RUNTIMEDIR}" ; \
- "${BOINCCMD}" ${password} --get_project_status | \
+ "${BOINCCMD}" --get_project_status | \
sed -n 's/\s*master URL: //p'); do
ebegin "Resuming ${url}"
start-stop-daemon --user "${USER}:${GROUP}" --quiet \
--chdir "${RUNTIMEDIR}" --exec "${BOINCCMD}" \
- -- ${password} --project ${url} resume
+ -- --project ${url} resume
eend $?
done
}
@@ -236,19 +209,13 @@ resume() {
suspend() {
env_check || return 1
- local password=""
-
- if need_passwd_arg; then
- password="--passwd \"$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")\""
- fi
-
for url in $(cd "${RUNTIMEDIR}" ; \
- "${BOINCCMD}" ${password} --get_project_status | \
+ "${BOINCCMD}" --get_project_status | \
sed -n 's/\s*master URL: //p'); do
ebegin "Suspending ${url}"
start-stop-daemon --user "${USER}:${GROUP}" --quiet \
--chdir "${RUNTIMEDIR}" --exec "${BOINCCMD}" \
- -- ${password} --project ${url} suspend
+ -- --project ${url} suspend
eend $?
done
}