summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2022-07-27 14:03:05 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-08-01 10:34:39 +0200
commit3b5cff7a666c493b0421d43a5742f318fb1e5485 (patch)
tree8ee085664e1ab6e3dd02ffd54bfc9f7a8b1c2aa2 /sci-misc/boinc
parentsci-misc/boinc: Untangle CUDA/OpenCL for nvidia and fix dependencies (diff)
downloadgentoo-3b5cff7a666c493b0421d43a5742f318fb1e5485.tar.gz
gentoo-3b5cff7a666c493b0421d43a5742f318fb1e5485.tar.bz2
gentoo-3b5cff7a666c493b0421d43a5742f318fb1e5485.zip
sci-misc/boinc: Add optfeature message to point out net-fs/cvmfs
CVMFS is needed to run ATLAS native tasks from LHC@home. But besides not being needed by anything else, it is also only available on x86 and amd64. Therefore this did not become a USE flag but an optional feature message. Bug: https://bugs.gentoo.org/811249 Closes: https://bugs.gentoo.org/811249 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Closes: https://github.com/gentoo/gentoo/pull/26619 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/boinc-7.20.2-r2.ebuild5
-rw-r--r--sci-misc/boinc/boinc-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/sci-misc/boinc/boinc-7.20.2-r2.ebuild b/sci-misc/boinc/boinc-7.20.2-r2.ebuild
index 5c03102ff4aa..f14534027d69 100644
--- a/sci-misc/boinc/boinc-7.20.2-r2.ebuild
+++ b/sci-misc/boinc/boinc-7.20.2-r2.ebuild
@@ -6,7 +6,7 @@ EAPI=8
MY_PV=$(ver_cut 1-2)
WX_GTK_VER=3.0-gtk3
-inherit autotools desktop flag-o-matic linux-info wxwidgets xdg-utils
+inherit autotools desktop flag-o-matic linux-info optfeature wxwidgets xdg-utils
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="https://boinc.berkeley.edu/"
@@ -195,6 +195,9 @@ pkg_postinst() {
elog "Run as root:"
elog "gpasswd -a boinc video"
elog
+
+ optfeature_header "If you want to run ATLAS native tasks by LHC@home, you need to install:"
+ optfeature "CERN VM filesystem support" net-fs/cvmfs
}
pkg_postrm() {
diff --git a/sci-misc/boinc/boinc-9999.ebuild b/sci-misc/boinc/boinc-9999.ebuild
index 08e8f1f9530c..07b9716f2970 100644
--- a/sci-misc/boinc/boinc-9999.ebuild
+++ b/sci-misc/boinc/boinc-9999.ebuild
@@ -8,7 +8,7 @@ EAPI=8
MY_PV=7.18
WX_GTK_VER=3.0-gtk3
-inherit autotools desktop flag-o-matic linux-info wxwidgets xdg-utils
+inherit autotools desktop flag-o-matic linux-info optfeature wxwidgets xdg-utils
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="https://boinc.berkeley.edu/"
@@ -198,6 +198,9 @@ pkg_postinst() {
elog "Run as root:"
elog "gpasswd -a boinc video"
elog
+
+ optfeature_header "If you want to run ATLAS native tasks by LHC@home, you need to install:"
+ optfeature "CERN VM filesystem support" net-fs/cvmfs
}
pkg_postrm() {