summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-23 11:35:19 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-23 11:46:39 +0100
commit5c5d388cd7a9888abe57ea54570fb11ee71acc50 (patch)
tree064a34b073b2371f86ed89124b02f5deeda7fad7 /sci-misc/flashdot/flashdot-1.1.4.ebuild
parentsci-biology/embassy-mse: Move use_enable call to local scope (diff)
downloadgentoo-5c5d388cd7a9888abe57ea54570fb11ee71acc50.tar.gz
gentoo-5c5d388cd7a9888abe57ea54570fb11ee71acc50.tar.bz2
gentoo-5c5d388cd7a9888abe57ea54570fb11ee71acc50.zip
sci-misc/flashdot: Move use() call to local scope
bump EAPI to 5 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=566554 Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-misc/flashdot/flashdot-1.1.4.ebuild')
-rw-r--r--sci-misc/flashdot/flashdot-1.1.4.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/sci-misc/flashdot/flashdot-1.1.4.ebuild b/sci-misc/flashdot/flashdot-1.1.4.ebuild
index 13938ad805d8..fe83fa9eefbc 100644
--- a/sci-misc/flashdot/flashdot-1.1.4.ebuild
+++ b/sci-misc/flashdot/flashdot-1.1.4.ebuild
@@ -1,34 +1,33 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=2
+EAPI=5
DESCRIPTION="Generator for psychophysical experiments"
HOMEPAGE="http://www.flashdot.info/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~tomka/files/${P}.tar.bz2"
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~tomka/files/${P}.tar.bz2"
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
IUSE="+ocamlopt"
-DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+DEPEND="
+ >=dev-lang/ocaml-3.10[ocamlopt?]
dev-ml/ocamlsdl
dev-ml/ocamlgsl
dev-ml/lablgl[glut]
x11-apps/xdpyinfo"
RDEPEND="${DEPEND}"
-MAKEOPTS="-j1 VERSION=${PV}"
-use ocamlopt || MAKEOPTS="${MAKEOPTS} TARGETS=flashdot_bytecode BYTECODENAME=flashdot"
-
-src_compile() {
- emake ${MAKEOPTS} || die "emake failed"
+src_prepare() {
+ MAKEOPTS+=" -j1 VERSION=${PV}"
+ use ocamlopt || MAKEOPTS+=" TARGETS=flashdot_bytecode BYTECODENAME=flashdot"
}
src_install() {
- emake ${MAKEOPTS} DESTDIR="${D}" CALLMODE=script install || die "install failed"
+ emake DESTDIR="${D}" CALLMODE=script install
}