summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2023-02-01 19:42:58 +0800
committerBenda Xu <heroxbd@gentoo.org>2023-02-01 23:03:55 +0800
commit0ee9c509b11291ff9614c945093ca94b74366c47 (patch)
treef68290045a14e583319836d3d777259d85483175 /sci-misc/vitables/vitables-3.0.2_p4.ebuild
parentsys-kernel/gentoo-kernel-bin: Bump to 5.10.166 (diff)
downloadgentoo-0ee9c509b11291ff9614c945093ca94b74366c47.tar.gz
gentoo-0ee9c509b11291ff9614c945093ca94b74366c47.tar.bz2
gentoo-0ee9c509b11291ff9614c945093ca94b74366c47.zip
sci-misc/vitables: bump to debian 3.0.2_p4, migrate nose to pytest.
Drop old. Closes: https://bugs.gentoo.org/878727 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-misc/vitables/vitables-3.0.2_p4.ebuild')
-rw-r--r--sci-misc/vitables/vitables-3.0.2_p4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-misc/vitables/vitables-3.0.2_p4.ebuild b/sci-misc/vitables/vitables-3.0.2_p4.ebuild
new file mode 100644
index 000000000000..c3764c5fcf38
--- /dev/null
+++ b/sci-misc/vitables/vitables-3.0.2_p4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A graphical tool for browsing / editing files in both PyTables and HDF5 formats"
+HOMEPAGE="https://vitables.org/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_$(ver_cut 1-3).orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_$(ver_cut 1-3)-$(ver_cut 5).debian.tar.xz"
+S="${WORKDIR}/ViTables-$(ver_cut 1-3)"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,${PYTHON_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ eapply ../debian/patches
+ default
+}
+
+python_test() {
+ virtx epytest
+}