summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-29 15:51:17 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-29 15:52:35 +0200
commit04beb399d78d9b2feb4ce274be0e972587eeccde (patch)
treee97ac92f34cb00747ddad06974029f3b275ee4e2 /sci-misc
parentdev-python/jupyterlab-lsp: add 4.0.1 (diff)
downloadgentoo-04beb399d78d9b2feb4ce274be0e972587eeccde.tar.gz
gentoo-04beb399d78d9b2feb4ce274be0e972587eeccde.tar.bz2
gentoo-04beb399d78d9b2feb4ce274be0e972587eeccde.zip
sci-misc/jupyterlab-desktop-bin: add 3.6.2.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.6.2.1.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 0a4aecd9424c..dc5ac3034d03 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1,3 +1,4 @@
DIST jupyterlab-desktop-bin-3.5.1.1.rpm 323640057 BLAKE2B d6516d922f28eed846af92be3bdccbf9c2d656c4056fabb118c3dd3d6d3bafc68e11cd7ffe5fa97172c2125da826b352758546d8fd4c2dd2a3748031f4c5b0b3 SHA512 3b46834532776b341f3b9b74e38d32c11bcf909634b8a2695f1d4d0c9cb829b4d5013f1349b099acd84cf40e17fa9ad9bb8f2ed5f134d0d7b521f599fc6227e0
DIST jupyterlab-desktop-bin-3.6.1.2.rpm 322845365 BLAKE2B 8bd1554a781b48c464314f1cdbd04886e00d61f518d47241b2a68f4da3ce551a7f0a96b008d895247512075b785533db94c3b3fc31f7e76c382d6da8cbb68ede SHA512 87367307b67e59bed6b0910c723ae6250a8fc1ba2fa1ae70cddd5661bcc831b5c23f656f1189d3eeccbf6632fa644032dc2e5039e93080f42a22d3607b32b8e9
DIST jupyterlab-desktop-bin-3.6.1.3.rpm 318822073 BLAKE2B 1ad32aab62592f6fece79fd8e9904ac7b7f092ad252513bd8812c8b7b6fb718afe09922ce825d7358816a0728395627effe8de833378e7d5dc429d1b9559e11e SHA512 4d40f06f3e7015055826b6a6317a2c5fc23a07e41b8bc55d8b6ad879b319a26458b7379753710da989dbb215ef319d36f5b7e4d1ed8c5caee8c7d6903d4afed5
+DIST jupyterlab-desktop-bin-3.6.2.1.rpm 320191697 BLAKE2B c4db82cb1a81d26bdb3923ee3726915a1613ae39bd3b7e413578835d883357b4f83abf700373e5452707eb2cb41e3f940ab04b968c3b42927826c2ccafaa46a8 SHA512 e2554202ac2772414b474cdd5a5addb56c3d7ceb1c451735b97facb5bda8f34e18d55611fc35ae0e0914357f783eb0fb697f6d9566f0f7da9fcba89f2cb8d8ad
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.6.2.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.6.2.1.ebuild
new file mode 100644
index 000000000000..4bb8e3351976
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.6.2.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ >=dev-python/jupyterlab-$(ver_cut 1-3)
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/JupyterLab/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ for size in {16,32,48,64,128,256,512}; do
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/jupyterlab-desktop.png"
+ done
+
+ domenu usr/share/applications/jupyterlab-desktop.desktop
+
+ local DESTDIR="/opt/JupyterLab"
+ pushd "opt/JupyterLab" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox chrome_crashpad_handler jupyterlab-desktop *.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+ popd || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}