summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-11-16 09:37:24 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-11-16 10:09:42 +0100
commit38be72661b9eac88ce248fb51d0af4a4bf7f9502 (patch)
tree1a081ce5d6bcd6c26386dac4cc8d482b48b32e1b /sci-misc
parentdev-util/android-sdk-update-manager: remove 24.4.1-r2 (diff)
downloadgentoo-38be72661b9eac88ce248fb51d0af4a4bf7f9502.tar.gz
gentoo-38be72661b9eac88ce248fb51d0af4a4bf7f9502.tar.bz2
gentoo-38be72661b9eac88ce248fb51d0af4a4bf7f9502.zip
sci-misc/jupyterlab-desktop: add package
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/jupyterlab-desktop/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop/jupyterlab-desktop-3.2.3.1.ebuild65
-rw-r--r--sci-misc/jupyterlab-desktop/metadata.xml12
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop/Manifest b/sci-misc/jupyterlab-desktop/Manifest
new file mode 100644
index 000000000000..efabb6bc2ac6
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop/Manifest
@@ -0,0 +1 @@
+DIST jupyterlab-desktop-3.2.3.1.rpm 252370944 BLAKE2B 1f62fab27146a06f58464da19c6184eeeb4d358f41ba2fcad56caeb712016aad3c09ced5b993811ccb6095b7ecc3105635698429c3f8065d83205d5948abdc58 SHA512 ab2e0a167d52122f8b3933007b08f117b6ce13203b995c084f4ab3b56adbc04e38aae81d0862a9a0b2935b643ab407cf9ff2cc0f92ad69178d585590d40ad63a
diff --git a/sci-misc/jupyterlab-desktop/jupyterlab-desktop-3.2.3.1.ebuild b/sci-misc/jupyterlab-desktop/jupyterlab-desktop-3.2.3.1.ebuild
new file mode 100644
index 000000000000..15ce362a0939
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop/jupyterlab-desktop-3.2.3.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/jupyterlab
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/JupyterLab/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}
diff --git a/sci-misc/jupyterlab-desktop/metadata.xml b/sci-misc/jupyterlab-desktop/metadata.xml
new file mode 100644
index 000000000000..af73f75812c1
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">jupyterlab/jupyterlab-desktop</remote-id>
+ <bugs-to>https://github.com/jupyterlab/jupyterlab-desktop/issues</bugs-to>
+ </upstream>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+</pkgmetadata>