summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2021-04-24 14:51:33 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-24 14:51:33 +0200
commit3bfe6e33619fbeab0b0d364fd6bdc43889290dc7 (patch)
tree9c63608810bdcaaab8de71dc87cabdfa6e849395 /sci-misc
parentsci-misc/boinc: Fix installation with imagemagick[-xml] (diff)
downloadgentoo-3bfe6e33619fbeab0b0d364fd6bdc43889290dc7.tar.gz
gentoo-3bfe6e33619fbeab0b0d364fd6bdc43889290dc7.tar.bz2
gentoo-3bfe6e33619fbeab0b0d364fd6bdc43889290dc7.zip
sci-misc/boinc: Bump to 7.16.16
The live ebuild is synced to this new version. Closes: https://bugs.gentoo.org/784635 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/Manifest1
-rw-r--r--sci-misc/boinc/boinc-7.16.16.ebuild208
-rw-r--r--sci-misc/boinc/boinc-9999.ebuild2
3 files changed, 210 insertions, 1 deletions
diff --git a/sci-misc/boinc/Manifest b/sci-misc/boinc/Manifest
index 6f1f72eff136..64ba107c3c56 100644
--- a/sci-misc/boinc/Manifest
+++ b/sci-misc/boinc/Manifest
@@ -1,3 +1,4 @@
DIST boinc-7.14.2.tar.gz 52236336 BLAKE2B fa97d3af9e9a650db409b24386e7950369ab2247469cd83d717d1b6dccb7952a0997763dad2285532cef6807f0460eb320edb3a162b6b20a70bae12159ec6b7f SHA512 dcb6d60893e8baad6282d5e4728387352e942375d988df9c2ad00022deaa9bc5ace967a1346e1b43b25342d2e477ab42e28640935d94e6950ee3716732c9c1af
DIST boinc-7.16.14.tar.gz 49623696 BLAKE2B dde4163040d122cf4707e4747b18120f64c31af5ea4ca778709d9dd3c2fb019eb10ecb6ee367b73ea245cb5ed93bac710f268db2e0408b32120c750915473575 SHA512 9315cd8344571ac64eecf12676a2d3d6c021577ecee7a92eff253185f7ddf5bf4d64503a819c625afafd258ad28c3879839016c431aa3099083a90194c7e6454
+DIST boinc-7.16.16.tar.gz 49599131 BLAKE2B 819ab85c19a684144711f77e669b892aa73c006b81c1d7ef7adbd9d580e1e8473ae27b52dc17953ee677c70fc78ed15df936afd740e629715f30f2b81d84ea6f SHA512 dd7042e176d6506c70de7866556ae73b2f45734df92038086d5b0414751f3da08dc571c49f0c26d747d3fb2577674d3ff8cdec7d3563861eaaaa5af9c1db0a0e
DIST boinc.tif 288208 BLAKE2B 156a99f08dcabc62a46874830600b9d237e64b650b8edf35db67b82006a67039a3965707194e8f0b25cfd65138b8700c0bfb877507418393b9cd3df32e94d260 SHA512 548e19b87fd70dbeb05687320b86aad39981c161b5b5b7e02fc3ce886d4c464c9bb763d5652d9895dd505ce247c7ff4490caa3d407e28f54ce889ffbab22d046
diff --git a/sci-misc/boinc/boinc-7.16.16.ebuild b/sci-misc/boinc/boinc-7.16.16.ebuild
new file mode 100644
index 000000000000..213bded49211
--- /dev/null
+++ b/sci-misc/boinc/boinc-7.16.16.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=$(ver_cut 1-2)
+WX_GTK_VER=3.0-gtk3
+
+inherit autotools desktop flag-o-matic linux-info systemd wxwidgets xdg-utils
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="https://boinc.ssl.berkeley.edu/"
+
+SRC_URI="X? ( https://boinc.berkeley.edu/logo/boinc_glossy2_512_F.tif -> ${PN}.tif )"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/BOINC/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI+=" https://github.com/BOINC/boinc/archive/client_release/${MY_PV}/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="X cuda curl_ssl_gnutls curl_ssl_libressl +curl_ssl_openssl"
+
+REQUIRED_USE="^^ ( curl_ssl_gnutls curl_ssl_libressl curl_ssl_openssl ) "
+
+# libcurl must not be using an ssl backend boinc does not support.
+# If the libcurl ssl backend changes, boinc should be recompiled.
+COMMON_DEPEND="
+ acct-group/boinc
+ acct-user/boinc
+ >=app-misc/ca-certificates-20080809
+ cuda? (
+ >=dev-util/nvidia-cuda-toolkit-2.1
+ >=x11-drivers/nvidia-drivers-180.22
+ )
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
+ sys-apps/util-linux
+ sys-libs/zlib
+ X? (
+ dev-db/sqlite:3
+ media-libs/freeglut
+ virtual/jpeg:0=
+ x11-libs/gtk+:3
+ x11-libs/libICE
+ >=x11-libs/libnotify-0.7
+ x11-libs/libSM
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,webkit]
+ virtual/jpeg
+ )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.4
+ app-text/docbook2X
+ sys-devel/gettext
+ X? ( virtual/imagemagick-tools[png,tiff] )
+"
+RDEPEND="${COMMON_DEPEND}
+ !app-admin/quickswitch
+"
+
+PATCHES=(
+ # >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed, bug 587462
+ "${FILESDIR}"/${PN}-${MY_PV}-fix_webview.patch
+)
+
+pkg_setup() {
+ # Bug 578750
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ if ! linux_config_exists; then
+ ewarn "Can't check the linux kernel configuration."
+ ewarn "You might be missing vsyscall support."
+ elif kernel_is -ge 4 4 \
+ && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
+ ewarn "You do not have vsyscall emulation enabled."
+ ewarn "This will prevent some boinc projects from running."
+ ewarn "Please enable vsyscall emulation:"
+ ewarn " CONFIG_LEGACY_VSYSCALL_EMULATE=y"
+ ewarn "in /usr/src/linux/.config, to be found at"
+ ewarn " Processor type and features --->"
+ ewarn " vsyscall table for legacy applications (None) --->"
+ ewarn " (X) Emulate"
+ ewarn "Alternatively, you can enable CONFIG_LEGACY_VSYSCALL_NATIVE."
+ ewarn "However, this has security implications and is not recommended."
+ fi
+ fi
+}
+
+src_prepare() {
+ # bug #732024
+ if test "x$(get_libdir)" = "xlib64"; then
+ sed -i -e 's,/:/lib:/usr/lib:,:/lib64:/usr/lib64:,g' m4/sah_check_lib.m4 || die
+ fi
+
+ default
+
+ # prevent bad changes in compile flags, bug 286701
+ sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
+
+ eautoreconf
+
+ # bug #732024
+ if test "x$(get_libdir)" = "xlib64"; then
+ sed -i -e 's,/lib\([ /;:"]\),/lib64\1,g' configure || die
+ fi
+}
+
+src_configure() {
+ use X && setup-wxwidgets
+
+ append-libs -L"${ESYSROOT}"/usr/$(get_libdir) -L"${ESYSROOT}"/$(get_libdir)
+
+ econf --disable-server \
+ --enable-client \
+ --enable-dynamic-client-linkage \
+ --disable-static \
+ --enable-unicode \
+ --with-ssl \
+ $(use_with X x) \
+ $(use_enable X manager) \
+ $(usex X --with-wx-config="${WX_CONFIG}" --without-wxdir)
+}
+
+src_install() {
+ default
+
+ keepdir /var/lib/${PN}
+
+ if use X; then
+ # Create new icons. bug 593362
+ local s SIZES=(16 22 24 32 36 48 64 72 96 128 192 256)
+ for s in "${SIZES[@]}"; do
+ # The convert command is not checked, because it will issue warnings and exit with
+ # an error code if imagemagick is used and was merged with USE="-xml", although the
+ # conversion has worked. See #766093
+ # Instead, newicon will fail if the conversion did not produce the icon.
+ convert "${DISTDIR}"/${PN}.tif -resize ${s}x${s} "${WORKDIR}"/boinc_${s}.png
+ newicon -s $s "${WORKDIR}"/boinc_${s}.png boinc.png
+ done
+ make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
+
+ # Rename the desktop file to boincmgr.desktop to (hot)fix bug 599910
+ mv "${ED}"/usr/share/applications/boincmgr{-${PN},}.desktop || \
+ die "Failed to rename desktop file"
+ fi
+
+ # cleanup cruft
+ rm -r "${ED}"/etc || die "rm failed"
+ find "${D}" -name '*.la' -delete || die "Removing .la files failed"
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.init.in > ${PN}.init || die
+ newinitd ${PN}.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ if use X; then
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+ fi
+
+ elog
+ elog "You are using the source compiled version of boinc."
+ use X && elog "The graphical manager can be found at /usr/bin/boincmgr"
+ elog
+ elog "You need to attach to a project to do anything useful with boinc."
+ elog "You can do this by running /etc/init.d/boinc attach"
+ elog "The howto for configuration is located at:"
+ elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
+ elog
+ # Add warning about the new password for the client, bug 121896.
+ if use X; then
+ elog "If you need to use the graphical manager the password is in:"
+ elog "/var/lib/boinc/gui_rpc_auth.cfg"
+ elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
+ elog "/etc/conf.d/boinc"
+ elog "You should change this password to something more memorable (can be even blank)."
+ elog "Remember to launch init script before using manager. Or changing the password."
+ elog
+ fi
+ elog "To be able to use CUDA or OpenCL you should add the boinc user to the video group."
+ elog "Run as root:"
+ elog "gpasswd -a boinc video"
+ elog
+ # Add information about BOINC supporting OpenCL
+ elog "BOINC supports OpenCL. To use it you have to eselect"
+ if use cuda; then
+ elog "nvidia as the OpenCL implementation, as you are using CUDA."
+ else
+ elog "the correct OpenCL implementation for your graphic card."
+ fi
+ elog
+}
+
+pkg_postrm() {
+ if use X; then
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+ fi
+}
diff --git a/sci-misc/boinc/boinc-9999.ebuild b/sci-misc/boinc/boinc-9999.ebuild
index 213bded49211..6040de51a820 100644
--- a/sci-misc/boinc/boinc-9999.ebuild
+++ b/sci-misc/boinc/boinc-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-MY_PV=$(ver_cut 1-2)
+MY_PV=7.16
WX_GTK_VER=3.0-gtk3
inherit autotools desktop flag-o-matic linux-info systemd wxwidgets xdg-utils