summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-18 15:40:40 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-18 16:13:17 +0100
commit51b538d989f0a048a80820133e08c05c84dfbabe (patch)
tree1e66a73385259bbe1b309beb29717f640a6753eb /sci-misc
parentnet-im/rocketchat-desktop-bin: drop 3.7.8 (diff)
downloadgentoo-51b538d989f0a048a80820133e08c05c84dfbabe.tar.gz
gentoo-51b538d989f0a048a80820133e08c05c84dfbabe.tar.bz2
gentoo-51b538d989f0a048a80820133e08c05c84dfbabe.zip
sci-misc/jupyterlab-desktop-bin: add 3.3.2.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.3.2.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 93fa8cf13034..8ec0e4a0268a 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab-desktop-bin-3.2.5.2.rpm 269694928 BLAKE2B c92a46c273d4b3edfedf9392ff65813366317003607ab27c359b995cd896591454fbf8460b6ce22d717e0d28ba2c7800bf346f18c23dd758e58b4c329b3164f1 SHA512 7720c727a2a027f0f45072c92186b9fe7ea911aa2168100995e79feac0e248e9d3dde2f2fadcd43b749c394f604f09a53db81eebf26fdac5396bba81f6c75904
DIST jupyterlab-desktop-bin-3.2.9.1.rpm 332914260 BLAKE2B 57940cfc761cf3710303de6d6adc895027cacd9c97c40fa1773785ca66a9e4fdb041aef1857222b5c9eedfb766050aff4752927f87986b9fa0052cb9301a77f7 SHA512 73e963943f6e1254523d645264b4b1ac56cb2118c23fbf9a45a82a46b26bea9e876ef22549b832eb13392533a32edec5432ae7c29546ca7798f573e27880a0ab
+DIST jupyterlab-desktop-bin-3.3.2.1.rpm 316847336 BLAKE2B 76812cccfdc52a5588f40fc0338136d1af94c08360226e2c90ec04bee3ba7a48829e1e8ebdd47303ee193a678f554d39e33ecb9e28e05a63f38ae6c54c995be1 SHA512 bcc37b7a6dcedbdfa24e7591a33f9c152647287738b4c5bf44af387445b6c73d4855fe238fed557ee6eae8399fc3bcc4f6b19f07e712ae7c73d7372dcf0df66c
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.3.2.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.3.2.1.ebuild
new file mode 100644
index 000000000000..15bdd61754eb
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.3.2.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/jupyterlab
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+ # add convenience symlink to launch from cli
+ dosym ../JupyterLab/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}