summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-28 19:37:03 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-28 20:21:18 +0200
commit63662c381c0f34a257bb747f7f0f8996c9cf3a16 (patch)
treec9d94f1a1566235442706f69b4eb6528049a15ea /sci-misc
parentapp-text/zotero-bin: drop 6.0.3 (diff)
downloadgentoo-63662c381c0f34a257bb747f7f0f8996c9cf3a16.tar.gz
gentoo-63662c381c0f34a257bb747f7f0f8996c9cf3a16.tar.bz2
gentoo-63662c381c0f34a257bb747f7f0f8996c9cf3a16.zip
sci-misc/jupyterlab-desktop-bin: add 3.3.2.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.3.2.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 3a66dc82e4ca..84a9aefb45ff 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST jupyterlab-desktop-bin-3.3.2.1.rpm 316847336 BLAKE2B 76812cccfdc52a5588f40fc0338136d1af94c08360226e2c90ec04bee3ba7a48829e1e8ebdd47303ee193a678f554d39e33ecb9e28e05a63f38ae6c54c995be1 SHA512 bcc37b7a6dcedbdfa24e7591a33f9c152647287738b4c5bf44af387445b6c73d4855fe238fed557ee6eae8399fc3bcc4f6b19f07e712ae7c73d7372dcf0df66c
+DIST jupyterlab-desktop-bin-3.3.2.2.rpm 316224896 BLAKE2B 93f2345f67648f5269b9a7c6f37a1a3275a787d8a8ee082c95270ec52cabbe037eaf968af3f27e2fafe6a6ccf1393755eb586bc26790a1703056c5ab764500dd SHA512 a3bdef78c1823c8aa734db3496c7ff8f2c56d77b13aef3d36364160f13ad6b9cde8c6b66ddb66fb386f50325fb04a62fec85bce1110a49df9f4cd3f257751941
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.3.2.2.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.3.2.2.ebuild
new file mode 100644
index 000000000000..15bdd61754eb
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.3.2.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/jupyterlab
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+ # add convenience symlink to launch from cli
+ dosym ../JupyterLab/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}