summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-22 14:33:51 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-22 14:33:51 +0100
commit6d238eb5784dbc5f0842444cb0de9a7ff077e656 (patch)
treef44fcd5610e0caf2cbdc849bae122f911c26a3b0 /sci-misc
parentdev-perl/CGI: Stabilize 4.600.0 hppa, #920987 (diff)
downloadgentoo-6d238eb5784dbc5f0842444cb0de9a7ff077e656.tar.gz
gentoo-6d238eb5784dbc5f0842444cb0de9a7ff077e656.tar.bz2
gentoo-6d238eb5784dbc5f0842444cb0de9a7ff077e656.zip
sci-misc/jupyterlab-desktop-bin: add 4.0.11.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.0.11.1.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index c035b799d1b9..b4f20c851051 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1 +1,2 @@
+DIST jupyterlab-desktop-bin-4.0.11.1.rpm 296558525 BLAKE2B c520defe5b5ba360e84e3d77a6049c2a115bb3f708f601901e4c2aaeee5b67c0b0d8a31532932633cbc4cb2560583bb39e2cd9cd543b32ef868a74eed0573b67 SHA512 24809df57d6c2aea542648b69fa6dc21d9f11dd2a7643ad7782252a0f9e5ae93936fd0f6451e1e6c854755cdf86bae2f2386ba43d28cbff3fc7b070089aaeab7
DIST jupyterlab-desktop-bin-4.0.7.1.rpm 268183073 BLAKE2B e04d0b74108b16fb4027a2cad296fd388c8a89d7fc218fa9f0be2c577ad890ecb6333ebfaacb187550068b3acb6bdbbd5031e0f07cbdd0166afde7e4e69f6c4c SHA512 ee1e07a7ddd57583d648eed05b9dbf9d0b047cc4c9efd7cb6d425e1f3397d43b1b52ca4fa3759e84ba18ee7e479c5548f00b580326d00ede6f2a28c07159e1bc
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.0.11.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.0.11.1.ebuild
new file mode 100644
index 000000000000..6e1754a4294c
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.0.11.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ >=dev-python/jupyterlab-$(ver_cut 1-3)
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/JupyterLab/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ local size=512
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/jupyterlab-desktop.png"
+
+ domenu usr/share/applications/jupyterlab-desktop.desktop
+
+ local DESTDIR="/opt/JupyterLab"
+ pushd "opt/JupyterLab" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox chrome_crashpad_handler jupyterlab-desktop *.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+ popd || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}