summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-10-27 09:15:26 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-10-27 09:47:54 +0200
commitaf85cf6b378cf7c229938f0b144333b6dd069f49 (patch)
tree65aa793bdd88487394fb7dbd99295ffd11ea6a4c /sci-misc
parentapp-text/zotero-bin: drop 6.0.26 (diff)
downloadgentoo-af85cf6b378cf7c229938f0b144333b6dd069f49.tar.gz
gentoo-af85cf6b378cf7c229938f0b144333b6dd069f49.tar.bz2
gentoo-af85cf6b378cf7c229938f0b144333b6dd069f49.zip
sci-misc/jupyterlab-desktop-bin: add 4.0.7.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.0.7.1.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 43aad07a74ba..249e3dc58ba6 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1,3 +1,4 @@
DIST jupyterlab-desktop-bin-3.6.3.1.rpm 273770065 BLAKE2B 69285092ad9e31d886a3e3e8d096d1c0e3c0c74f27a05d722025d9412751035447cb8989cb0fd4410618f78ca753d2071941424390565e6891fdcaec061e03f5 SHA512 e48cf23da01001639cbe774bc38a4d4b702906aac3432d0b210bb4481378f87456c6b0d9bc4bed51dbbc6a38bbc24383676be56deae9ed993daf49933b0ed4d6
DIST jupyterlab-desktop-bin-4.0.0.1.rpm 262569685 BLAKE2B a39d488f4b90235ab6e18744fe35720d44157da794e33dd0eec62ee6b62d4924f055478cc9325e83b98b8fdf2f946251635613490deaf862db475e1bbb6f5f23 SHA512 b5534652283632d0e96e9a42f1a1bcbb7206af7d51dd0140c165c0fd739349d3d05ddf0aaa9f4df0c4cfb99fd4cbed43a2bc85678ed72d6a2bc2926dce91f290
DIST jupyterlab-desktop-bin-4.0.2.1.rpm 263334769 BLAKE2B 0bc68c9a5e82af5ab16fc0a5925fabccbee1f9ba92cb47e4f767e48114bb9c1ca42e7194878c7ac02a1409877f3b5dfbf869c4d5cad73676eb2edfd0bccf18b7 SHA512 227bca1becebbb38a94e32d2e563090a60ca9062ba1aed82740cdd82f4c556a9ef15a1bb763ab4f872199e071366a2814d4905a6720f0af942ab0b248a6fd388
+DIST jupyterlab-desktop-bin-4.0.7.1.rpm 268183073 BLAKE2B e04d0b74108b16fb4027a2cad296fd388c8a89d7fc218fa9f0be2c577ad890ecb6333ebfaacb187550068b3acb6bdbbd5031e0f07cbdd0166afde7e4e69f6c4c SHA512 ee1e07a7ddd57583d648eed05b9dbf9d0b047cc4c9efd7cb6d425e1f3397d43b1b52ca4fa3759e84ba18ee7e479c5548f00b580326d00ede6f2a28c07159e1bc
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.0.7.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.0.7.1.ebuild
new file mode 100644
index 000000000000..8cc3358b66ad
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.0.7.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ >=dev-python/jupyterlab-$(ver_cut 1-3)
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/JupyterLab/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ local size=512
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/jupyterlab-desktop.png"
+
+ domenu usr/share/applications/jupyterlab-desktop.desktop
+
+ local DESTDIR="/opt/JupyterLab"
+ pushd "opt/JupyterLab" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox chrome_crashpad_handler jupyterlab-desktop *.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+ popd || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}