summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-01-02 20:16:02 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-02 20:16:02 +0100
commitb8daa77e734102820c691daaab5a82ddabd17b5d (patch)
treeaaa18bfef89324b4e0e49aa70d0f930f65811c70 /sci-misc
parentsci-calculators/transcalc: Fix -fno-common (diff)
downloadgentoo-b8daa77e734102820c691daaab5a82ddabd17b5d.tar.gz
gentoo-b8daa77e734102820c691daaab5a82ddabd17b5d.tar.bz2
gentoo-b8daa77e734102820c691daaab5a82ddabd17b5d.zip
sci-misc/oww: Port to EAPI 7
Closes: https://bugs.gentoo.org/712476 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/oww/files/oww-0.86.5-musl.patch20
-rw-r--r--sci-misc/oww/oww-0.86.5.ebuild33
2 files changed, 38 insertions, 15 deletions
diff --git a/sci-misc/oww/files/oww-0.86.5-musl.patch b/sci-misc/oww/files/oww-0.86.5-musl.patch
new file mode 100644
index 000000000000..2d863a53164b
--- /dev/null
+++ b/sci-misc/oww/files/oww-0.86.5-musl.patch
@@ -0,0 +1,20 @@
+--- a/src/applctn.h
++++ b/src/applctn.h
+@@ -1,3 +1,5 @@
++#include <stdint.h>
++
+ void applctn_pre_init(int *argc, char ***argv) ;
+ void applctn_init(int *argc, char ***argv) ;
+ int applctn_startup_finished(void) ; /* Function to call in state_startup */
+--- a/src/ownet.h
++++ b/src/ownet.h
+@@ -42,9 +42,7 @@
+ //--------------------------------------------------------------//
+ #include <stdlib.h>
+ #include <stdio.h>
+-#ifdef __FreeBSD__
+ #include <sys/types.h>
+-#endif
+ //#include <windows.h>
+
+ //--------------------------------------------------------------//
diff --git a/sci-misc/oww/oww-0.86.5.ebuild b/sci-misc/oww/oww-0.86.5.ebuild
index 83eafaaa6ac2..f274c467b343 100644
--- a/sci-misc/oww/oww-0.86.5.ebuild
+++ b/sci-misc/oww/oww-0.86.5.ebuild
@@ -1,38 +1,41 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils
+inherit autotools
DESCRIPTION="A one-wire weather station for Dallas Semiconductor"
HOMEPAGE="http://oww.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="Artistic"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gtk nls usb"
RDEPEND="
net-misc/curl
gtk? ( x11-libs/gtk+:2 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-0.86.4-build.patch
"${FILESDIR}"/${P}-format-security.patch
- )
+ "${FILESDIR}"/${P}-musl.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
src_configure() {
- local myeconfargs=(
- --enable-interactive
- $(use_enable nls)
- $(use_enable gtk gui)
+ econf \
+ --enable-interactive \
+ $(use_enable nls) \
+ $(use_enable gtk gui) \
$(use_with usb)
- )
- autotools-utils_src_configure
}