summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2021-06-25 16:50:51 +0200
committerGuilherme Amadio <amadio@gentoo.org>2021-06-28 12:45:01 +0200
commit85a61a3b6978b0b869367928bc47507503fe9001 (patch)
tree9835fe8ed335009832703cf8fdff8b04971fcfbe /sci-physics/clhep
parentx11-misc/autorandr: initial import (diff)
downloadgentoo-85a61a3b6978b0b869367928bc47507503fe9001.tar.gz
gentoo-85a61a3b6978b0b869367928bc47507503fe9001.tar.bz2
gentoo-85a61a3b6978b0b869367928bc47507503fe9001.zip
sci-physics/clhep: version bump to 2.4.4.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/clhep')
-rw-r--r--sci-physics/clhep/Manifest1
-rw-r--r--sci-physics/clhep/clhep-2.4.4.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-physics/clhep/Manifest b/sci-physics/clhep/Manifest
index e67a3ec6935d..1a028dc31e39 100644
--- a/sci-physics/clhep/Manifest
+++ b/sci-physics/clhep/Manifest
@@ -1,2 +1,3 @@
DIST clhep-2.4.1.3.tgz 1537908 BLAKE2B 92fd1fcc415b01d8efa44be67c3bf9e58af2b4d18b6e7ee2161fbc20312428a6f17eacc09150ccff7fefb1686161518042f5c2f7558ff00b4d5696d002432ece SHA512 f7a52b353dc2c6d30cb7d307af71a028838ec674af2a50fe0199335d0b0f7fb4b84489ccfd12f21ecb7b1327acbc87065e7e87363308fd0caad5748a657aac13
DIST clhep-2.4.4.0.tgz 1541722 BLAKE2B 077048ea3ce94de88f08a1ae51ab9af892385d6747ed9f875e13b5aacc725e85f723031d42f526ca53050c07dad621053008c71d0f255f32893724f3e8189e52 SHA512 3ae88c8f31877c6e2cac7f7612946e9989186876c66015e6bfeab19260814c8a8bfb21fa28dd251cd2c43e4e3f63f336249c430c984f84810441603e949ecb5d
+DIST clhep-2.4.4.2.tgz 1541867 BLAKE2B 69f23c298db57fbd23a505facd993725f4f21b410463069570e98826dc96d54f309b010df27a5fe910c756bfb1dcdffdb9b47452ef5ddadd5a91ed81a1d9566e SHA512 c267e113111c139f4048db774c81167e53a70d4911f8106c3fabf5980935dfc9b451108385e9d8b8dccace99b4732a21ec0ea2fb86004bb85d04c02cfa54a619
diff --git a/sci-physics/clhep/clhep-2.4.4.2.ebuild b/sci-physics/clhep/clhep-2.4.4.2.ebuild
new file mode 100644
index 000000000000..ab61250e0377
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.4.4.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://proj-clhep.web.cern.ch/proj-clhep/"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/dist1/${P}.tgz"
+LICENSE="GPL-3 LGPL-3"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+IUSE="doc test threads"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # respect flags
+ sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
+ # dont build test if not asked
+ if ! use test; then
+ cmake_comment_add_subdirectory test
+ fi
+ # gentoo doc directory
+ if use doc; then
+ grep -rl 'share/doc/CLHEP' |
+ xargs sed -i \
+ -e "s:share/doc/CLHEP:share/doc/${PF}:" \
+ {.,*}/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLHEP_BUILD_DOCS=$(usex doc)
+ -DCLHEP_SINGLE_THREAD=$(usex threads no yes)
+ )
+ cmake_src_configure
+}