summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-06-30 11:53:19 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-06-30 11:56:44 +0800
commit0cc885f518823b618edec214114213ef67c29aae (patch)
treeef97cb4597d769e0c8e3774cb3dbc68a926747d4 /sci-physics/geant-data/geant-data-4.10.05.ebuild
parentsci-physics/geant: version bump. (diff)
downloadgentoo-0cc885f518823b618edec214114213ef67c29aae.tar.gz
gentoo-0cc885f518823b618edec214114213ef67c29aae.tar.bz2
gentoo-0cc885f518823b618edec214114213ef67c29aae.zip
sci-physics/geant-data: version bump.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-physics/geant-data/geant-data-4.10.05.ebuild')
-rw-r--r--sci-physics/geant-data/geant-data-4.10.05.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-physics/geant-data/geant-data-4.10.05.ebuild b/sci-physics/geant-data/geant-data-4.10.05.ebuild
new file mode 100644
index 000000000000..df59a575cc3f
--- /dev/null
+++ b/sci-physics/geant-data/geant-data-4.10.05.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Data files for Geant4 physical processes"
+HOMEPAGE="http://geant4.cern.ch/"
+
+GEANT4_DATA="
+ G4NDL.4.5
+ G4EMLOW.7.7
+ G4PhotonEvaporation.5.3
+ G4RadioactiveDecay.5.3
+ G4SAIDDATA.2.0
+ G4PARTICLEXS.1.1
+ G4ABLA.3.1
+ G4INCL.1.0
+ G4PII.1.3
+ G4ENSDFSTATE.2.2
+ G4RealSurface.2.1.1
+ G4TENDL.1.3.2"
+
+SRC_COM="http://geant4.cern.ch/support/source"
+for d in ${GEANT4_DATA}; do
+ SRC_URI="${SRC_URI} ${SRC_COM}/${d}.tar.gz"
+done
+unset d
+
+LICENSE="geant4"
+SLOT="4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=sci-physics/geant-${PV}:4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # unpack in destination only to avoid copy
+ return
+}
+
+src_install() {
+ sed -n "s,export \(G4.\+DATA=\"\).*\(/share/Geant.\+/data/.\+\) > /dev/null ; pwd\`,\1${EPREFIX}/usr\2,p" \
+ "${EPREFIX}/usr/bin/geant4.sh" > 99geant-data || die
+ doenvd 99geant-data
+ local g4dir=/usr/$(sed -n 's|.*/\(share/Geant4.*/data\).*|\1|p' "${EPREFIX}/usr/bin/geant4.sh" | tail -n 1)
+ dodir ${g4dir}
+ cd "${ED%/}/${g4dir}" || die
+ unpack ${A}
+}