summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2019-07-15 21:42:38 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-18 17:45:44 +0200
commit2acec32e7fff3d46567f29fd49506541148a96ef (patch)
treeb30cb47b1ae48d3f2c078010fb8600d12c907300 /sci-physics/geant-vmc/geant-vmc-9999.ebuild
parentmedia-gfx/rawtherapee: Drop 5.4 (diff)
downloadgentoo-2acec32e7fff3d46567f29fd49506541148a96ef.tar.gz
gentoo-2acec32e7fff3d46567f29fd49506541148a96ef.tar.bz2
gentoo-2acec32e7fff3d46567f29fd49506541148a96ef.zip
sci-physics/geant-vmc: Ebuild fixes and updates.
- Bump to EAPI 7 (revbump). - Block >=sci-physics/geant-4.10.05 for =geant-vmc-4.3.6. - Correct dependency on sci-physics/root[c++11]. - Add missing dependency on sci-physics/root[vmc]. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-physics/geant-vmc/geant-vmc-9999.ebuild')
-rw-r--r--sci-physics/geant-vmc/geant-vmc-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
index 2156a04588fa..ae53bfcd41d1 100644
--- a/sci-physics/geant-vmc/geant-vmc-9999.ebuild
+++ b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils eapi7-ver
+inherit cmake-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -11,8 +11,8 @@ if [[ ${PV} == *9999* ]]; then
else
DOWN_PV=$(ver_cut 2-)
SRC_URI="http://root.cern.ch/download/vmc/geant4_vmc.${DOWN_PV}.tar.gz"
- SOURCE_PV=$(ver_rs 1- - ${DOWN_PV})
- S="${WORKDIR}/geant4_vmc-${SOURCE_PV}"
+ SOURCE_PV=$(ver_rs 1- . ${DOWN_PV})
+ S="${WORKDIR}/geant4_vmc.${SOURCE_PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
@@ -23,11 +23,10 @@ LICENSE="GPL-2"
SLOT="4"
IUSE="doc examples geant3 +g4root +mtroot vgm test"
-# sci-physics/root[root7] flag activates std=c++14, which we could only support if also Geant is built with it.
-# Disable for now.
+# sci-physics/root[c++11] required to match sci-physics/geant flags.
RDEPEND="
>=sci-physics/geant-4.10.03:=[opengl,geant3?]
- sci-physics/root:=[-root7]
+ sci-physics/root:=[c++11,vmc]
vgm? ( >=sci-physics/vgm-4.4:= )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
@@ -35,6 +34,7 @@ RESTRICT="
!geant3? ( test )
!g4root? ( test )
!mtroot? ( test )
+ !test? ( test )
!vgm? ( test )"
DOCS=(