summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-11-03 23:18:11 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-11-03 23:19:58 +0100
commitc53be5da17dbf26e1c7752d00f80ad6ec879f8ea (patch)
tree24d19337b4d8b2f5857ebf2e8e0b887035d8e2a2 /sci-physics/qmeq/qmeq-1.0.ebuild
parentnet-im/libcommuni: drop old version (diff)
downloadgentoo-c53be5da17dbf26e1c7752d00f80ad6ec879f8ea.tar.gz
gentoo-c53be5da17dbf26e1c7752d00f80ad6ec879f8ea.tar.bz2
gentoo-c53be5da17dbf26e1c7752d00f80ad6ec879f8ea.zip
sci-physics/qmeq: New package
See also https://arxiv.org/abs/1706.10104 and http://dx.doi.org/10.1016/j.cpc.2017.07.024 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sci-physics/qmeq/qmeq-1.0.ebuild')
-rw-r--r--sci-physics/qmeq/qmeq-1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-physics/qmeq/qmeq-1.0.ebuild b/sci-physics/qmeq/qmeq-1.0.ebuild
new file mode 100644
index 000000000000..db03248cf2e3
--- /dev/null
+++ b/sci-physics/qmeq/qmeq-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Quantum master equation package for Quantum dot transport calculations"
+HOMEPAGE="https://github.com/gedaskir/qmeq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+IUSE=""
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+"