summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Lodovici <fedelodo@users.noreply.github.com>2018-02-23 14:52:45 +0100
committerGuilherme Amadio <amadio@gentoo.org>2018-03-09 09:29:04 +0100
commit23ff9c6da1eb892b12e7a0b1edbf4d87ae4f6b26 (patch)
tree7cae44e0e20f8fb60b16d228f05430921c5c8854 /sci-physics/rivet
parentx11-misc/lightdm: Bump to version 1.25.2 (diff)
downloadgentoo-23ff9c6da1eb892b12e7a0b1edbf4d87ae4f6b26.tar.gz
gentoo-23ff9c6da1eb892b12e7a0b1edbf4d87ae4f6b26.tar.bz2
gentoo-23ff9c6da1eb892b12e7a0b1edbf4d87ae4f6b26.zip
sci-pyhsics/rivet: bump to 2.6.0
Diffstat (limited to 'sci-physics/rivet')
-rw-r--r--sci-physics/rivet/Manifest1
-rw-r--r--sci-physics/rivet/rivet-2.6.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-physics/rivet/Manifest b/sci-physics/rivet/Manifest
index eb516cf64816..03d3f3ad1e5a 100644
--- a/sci-physics/rivet/Manifest
+++ b/sci-physics/rivet/Manifest
@@ -1,3 +1,4 @@
DIST Rivet-2.3.0.tar.bz2 2742948 BLAKE2B 3a90927720b9d0badf0c7278d61a848c660be8196ed62d3a1a0f04dd6c9537d60f223c47cf9385b1e7a919b28caea4bb1b605b5d3b675388e3b5cda920bffeb1 SHA512 b51b77f80d69156dead899312cad838bc03479a072e163df50262e86790503515f8ab8af93723c3cbd33007d9812aa10581b2c960d92bc1fcf5031d27018d239
DIST Rivet-2.5.2.tar.bz2 3005023 BLAKE2B ffccefbe38f3b6ddab16d3b9138d9779ab4ad2f466094675ed0d13c59d0bfd5efe753ca8bec57b31377ba42d76f313dce18af158cc61daace425d4bbdfb6b055 SHA512 dd84143eb5d4b24ae2e5ace175e349fe48b4b5e6a47b3aa031a4144c635f016e8bbd731ed3f96b5c2f52c7df8ff0f1db70750fc45381bdfcdd469fd4c058beef
+DIST Rivet-2.6.0.tar.bz2 3527799 BLAKE2B a0ffe7a73ed1120cd3944d3c845ed9387528e7645554c589fda0bfcac694e36f24ee78914e916c51f3a978659933b4e8934e0373f26e4a3ba7597714fc9a939f SHA512 49c381d88075715e23942bb02066b189305077581cd64b708ccaf79436202fe1c9d7989fc1f35dfeffdc643adb39283710fdf33fc87407cfb7ddd3e9d2297feb
DIST refs.bib 16907 BLAKE2B 70c11f86c8ebf6386615b3e900280d1a2677dc82d99f944ac670f52320e05355352dd4017a48ae2af52dfd6f46a92a0d2d65bde4c271589ba4e66b3e7b68982c SHA512 64755e6aeaa1f0b3fb76a33ffdf226bcd42ee597a78a8d458b728f0e6f576d4dafbb276a0498c3b573d23054ccbf54ada6f6c12faf52dbfbeef2372094d01181
diff --git a/sci-physics/rivet/rivet-2.6.0.ebuild b/sci-physics/rivet/rivet-2.6.0.ebuild
new file mode 100644
index 000000000000..91d10173c782
--- /dev/null
+++ b/sci-physics/rivet/rivet-2.6.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools bash-completion-r1 python-single-r1
+
+DESCRIPTION="Toolkit for validation of Monte Carlo HEP event generators"
+HOMEPAGE="http://rivet.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${P^}.tar.bz2
+ doc? ( https://rivet.hepforge.org/trac/export/8a05acecd26c18f368f4b748da2d5aa2db46be6c/doc/refs.bib )"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=
+ sci-libs/gsl:=
+ sci-physics/fastjet[plugins]
+ sci-physics/hepmc
+ >=sci-physics/yoda-1.5.0[python]
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex,dot] )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P^}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack "${P^}.tar.bz2"
+
+ if use doc; then
+ # refs.bib is missing in tarball (reported upstream)
+ cp "${DISTDIR}"/refs.bib "${S}"/doc || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Install rivet-manual.pdf to docdir intead of pkgdatadir
+ sed -i '/pkgdata_DATA = $(DOCS)/s/pkgdata/doc/' doc/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python pyext) \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen) \
+ $(use_enable doc pdfmanual)
+}
+
+src_compile() {
+ use doc && export VARTEXFONTS="${T}/fonts"
+ default
+
+ if use doc; then
+ doxygen Doxyfile || die
+ HTML_DOCS+=( doxy/html/. )
+ fi
+}
+
+src_install() {
+ default
+ newbashcomp "${ED%/}"/usr/share/Rivet/rivet-completion rivet
+ rm -f "${ED%/}"/usr/share/Rivet/rivet-completion || die
+}