summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-08-02 16:07:33 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-08-05 17:28:35 +0200
commit9e0ab0d8ef866b1aa2714ed8a45f37c27ebed7d1 (patch)
tree748fec1e65c68c959af92a8df567d6683b111136 /sci-physics/root
parentdev-libs/intel-neo: bump to 19.30.13641 (diff)
downloadgentoo-9e0ab0d8ef866b1aa2714ed8a45f37c27ebed7d1.tar.gz
gentoo-9e0ab0d8ef866b1aa2714ed8a45f37c27ebed7d1.tar.bz2
gentoo-9e0ab0d8ef866b1aa2714ed8a45f37c27ebed7d1.zip
sci-physics/root: add nosplash USE flag
This disables ROOT's splash screen by default. Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/metadata.xml1
-rw-r--r--sci-physics/root/root-6.12.06-r10.ebuild (renamed from sci-physics/root/root-6.12.06-r9.ebuild)10
-rw-r--r--sci-physics/root/root-6.14.08-r3.ebuild (renamed from sci-physics/root/root-6.14.08-r2.ebuild)12
-rw-r--r--sci-physics/root/root-6.16.00-r2.ebuild (renamed from sci-physics/root/root-6.16.00-r1.ebuild)12
-rw-r--r--sci-physics/root/root-6.18.00-r1.ebuild (renamed from sci-physics/root/root-6.18.00.ebuild)10
-rw-r--r--sci-physics/root/root-9999.ebuild10
6 files changed, 38 insertions, 17 deletions
diff --git a/sci-physics/root/metadata.xml b/sci-physics/root/metadata.xml
index f2ba440c8cea..8eb44b130ef3 100644
--- a/sci-physics/root/metadata.xml
+++ b/sci-physics/root/metadata.xml
@@ -33,6 +33,7 @@
<flag name="libcxx">Build ROOT against <pkg>sys-libs/libcxx</pkg></flag>
<flag name="memstat">Build memory statistics library, helps to detect memory leaks</flag>
<flag name="minuit">Build ROOT's internal versions of minuit (fortran) and minuit2 (C++)</flag>
+ <flag name="nosplash">Disable ROOT's splash screen by default</flag>
<flag name="pythia6">Build the interface for <pkg>sci-physics/pythia</pkg> version 6.x </flag>
<flag name="pythia8">Build the interface for <pkg>sci-physics/pythia</pkg> version 8.x </flag>
<flag name="R">Enable support for <pkg>dev-lang/R</pkg></flag>
diff --git a/sci-physics/root/root-6.12.06-r9.ebuild b/sci-physics/root/root-6.12.06-r10.ebuild
index 244f4d26df85..43923b51d70d 100644
--- a/sci-physics/root/root-6.12.06-r9.ebuild
+++ b/sci-physics/root/root-6.12.06-r10.ebuild
@@ -18,9 +18,9 @@ SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
IUSE="+X aqua +asimage +davix emacs +examples fits fftw fortran
+gdml graphviz +gsl http jemalloc kerberos ldap libcxx memstat
- +minuit mysql odbc +opengl oracle postgres prefix pythia6 pythia8
- +python qt5 R +roofit root7 shadow sqlite +ssl table +tbb test
- +threads +tiff +tmva +unuran vc xinetd +xml xrootd zeroconf"
+ +minuit mysql nosplash odbc +opengl oracle postgres prefix pythia6
+ pythia8 +python qt5 R +roofit root7 shadow sqlite +ssl table +tbb
+ test +threads +tiff +tmva +unuran vc xinetd +xml xrootd zeroconf"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
@@ -133,6 +133,10 @@ src_prepare() {
# CSS should use local images
sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
+ if use nosplash; then
+ sed -i -e '/bool gNoLogo/s@false@true@' rootx/src/rootx.cxx
+ fi
+
hprefixify core/clingutils/CMakeLists.txt
}
diff --git a/sci-physics/root/root-6.14.08-r2.ebuild b/sci-physics/root/root-6.14.08-r3.ebuild
index 69718f3f6257..58b0d4a14fbe 100644
--- a/sci-physics/root/root-6.14.08-r2.ebuild
+++ b/sci-physics/root/root-6.14.08-r3.ebuild
@@ -18,10 +18,10 @@ SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
fits fftw fortran +gdml graphviz +gsl http jemalloc kerberos ldap
- libcxx memstat +minuit mysql odbc +opengl oracle postgres prefix
- pythia6 pythia8 +python qt5 R +roofit root7 shadow sqlite +ssl
- table +tbb test +threads +tiff +tmva +unuran vc xinetd +xml xrootd
- zeroconf"
+ libcxx memstat +minuit mysql nosplash odbc +opengl oracle postgres
+ prefix pythia6 pythia8 +python qt5 R +roofit root7 shadow sqlite
+ +ssl table +tbb test +threads +tiff +tmva +unuran vc xinetd +xml
+ xrootd zeroconf"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
@@ -131,6 +131,10 @@ src_prepare() {
# CSS should use local images
sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
+ if use nosplash; then
+ sed -i -e '/bool gNoLogo/s@false@true@' rootx/src/rootx.cxx
+ fi
+
hprefixify core/clingutils/CMakeLists.txt
}
diff --git a/sci-physics/root/root-6.16.00-r1.ebuild b/sci-physics/root/root-6.16.00-r2.ebuild
index c893ead5cca2..62d33225b7aa 100644
--- a/sci-physics/root/root-6.16.00-r1.ebuild
+++ b/sci-physics/root/root-6.16.00-r2.ebuild
@@ -18,10 +18,10 @@ SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
fits fftw fortran +gdml graphviz +gsl http jemalloc kerberos ldap
- libcxx memstat +minuit mysql odbc +opengl oracle postgres prefix
- pythia6 pythia8 +python qt5 R +roofit root7 shadow sqlite +ssl
- table +tbb test +threads +tiff +tmva +unuran vc xinetd +xml xrootd
- zeroconf"
+ libcxx memstat +minuit mysql nosplash odbc +opengl oracle postgres
+ prefix pythia6 pythia8 +python qt5 R +roofit root7 shadow sqlite
+ +ssl table +tbb test +threads +tiff +tmva +unuran vc xinetd +xml
+ xrootd zeroconf"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
@@ -133,6 +133,10 @@ src_prepare() {
# CSS should use local images
sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
+ if use nosplash; then
+ sed -i -e '/bool gNoLogo/s@false@true@' rootx/src/rootx.cxx
+ fi
+
hprefixify core/clingutils/CMakeLists.txt
}
diff --git a/sci-physics/root/root-6.18.00.ebuild b/sci-physics/root/root-6.18.00-r1.ebuild
index 7d471c4b2069..a9a02ada21d2 100644
--- a/sci-physics/root/root-6.18.00.ebuild
+++ b/sci-physics/root/root-6.18.00-r1.ebuild
@@ -18,9 +18,9 @@ SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
fits fftw fortran +gdml graphviz +gsl http jemalloc libcxx memstat
- +minuit mysql odbc +opengl oracle postgres prefix pythia6 pythia8
- +python qt5 R +roofit root7 shadow sqlite +ssl +tbb test +threads
- +tiff +tmva +unuran vc +vmc +xml xrootd"
+ +minuit mysql nosplash odbc +opengl oracle postgres prefix pythia6
+ pythia8 +python qt5 R +roofit root7 shadow sqlite +ssl +tbb test
+ +threads +tiff +tmva +unuran vc +vmc +xml xrootd"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
@@ -127,6 +127,10 @@ src_prepare() {
# CSS should use local images
sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
+ if use nosplash; then
+ sed -i -e '/bool gNoLogo/s@false@true@' rootx/src/rootx.cxx
+ fi
+
hprefixify core/clingutils/CMakeLists.txt
}
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index d300c32a9370..dbe4236df64c 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -17,9 +17,9 @@ HOMEPAGE="https://root.cern"
IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
fits fftw fortran +gdml graphviz +gsl http libcxx +minuit mysql
- odbc +opengl oracle postgres prefix pythia6 pythia8 +python qt5 R
- +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc vmc
- +xml xrootd"
+ nosplash odbc +opengl oracle postgres prefix pythia6 pythia8
+ +python qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva
+ +unuran vc vmc +xml xrootd"
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
@@ -138,6 +138,10 @@ src_prepare() {
# CSS should use local images
sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
+ if use nosplash; then
+ sed -i -e '/bool gNoLogo/s@false@true@' rootx/src/rootx.cxx
+ fi
+
hprefixify core/clingutils/CMakeLists.txt
}