summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-08-23 14:42:45 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2015-08-23 14:42:45 +0200
commitf68b678539fcd92d00a601a276275749c868d739 (patch)
treea631817495fa42397255daf0c660245045049871 /sci-physics/thepeg/files
parentsci-physics/root-6.*: fix bug 558270 (diff)
downloadgentoo-f68b678539fcd92d00a601a276275749c868d739.tar.gz
gentoo-f68b678539fcd92d00a601a276275749c868d739.tar.bz2
gentoo-f68b678539fcd92d00a601a276275749c868d739.zip
sci-physics/thepeg: initial import from the science overlay
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-physics/thepeg/files')
-rw-r--r--sci-physics/thepeg/files/thepeg-1.8.3-java.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-physics/thepeg/files/thepeg-1.8.3-java.patch b/sci-physics/thepeg/files/thepeg-1.8.3-java.patch
new file mode 100644
index 000000000000..45b0e9559ad5
--- /dev/null
+++ b/sci-physics/thepeg/files/thepeg-1.8.3-java.patch
@@ -0,0 +1,37 @@
+--- java/Makefile.am
++++ java/Makefile.am
+@@ -11,8 +12,7 @@
+
+ CLEANFILES = ThePEG.jar thepeg.sh
+
+-jardir = $(pkglibdir)
+-nodist_jar_DATA = ThePEG.jar
++noinst_DATA = ThePEG.jar
+
+ dist_noinst_DATA = $(JAVASOURCES) jar-manifest
+
+@@ -34,7 +34,7 @@
+ $(JAR) cmf ThePEG/jar-manifest ThePEG.jar ThePEG/*.class
+
+ thepeg.sh: thepeg.install Makefile
+- sed -e s:@pkglibdir[@]:$(pkglibdir):g \
++ sed -e s:@datadir[@]:$(datadir):g \
+ -e s:@bindir[@]:$(bindir):g \
+ -e s:@java[@]:$(JAVA):g $(srcdir)/thepeg.install > thepeg.sh
+ chmod +x thepeg.sh
+--- java/thepeg.install
++++ java/thepeg.install
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-pkglibdir=@pkglibdir@
++source @datadir@/thepeg/package.env
+ bindir=@bindir@
+
+ ThePEG_CMD="${bindir}/setupThePEG"
+@@ -19,4 +19,4 @@
+
+
+
+-exec @java@ ${HEADLESS} -jar ${pkglibdir}/ThePEG.jar ${ThePEG_CMD} "$@"
++exec @java@ ${HEADLESS} -jar ${CLASSPATH} ${ThePEG_CMD} "$@"