summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2023-01-24 10:55:32 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-01-26 12:10:52 +0100
commit8119d73192a628b59ec3cfbaa435a7dac4048810 (patch)
tree3c3a0734bf956740e13044406d66ca5af34676e4 /sci-physics/vgm
parentdev-python/yapf: Add GH remote-id (diff)
downloadgentoo-8119d73192a628b59ec3cfbaa435a7dac4048810.tar.gz
gentoo-8119d73192a628b59ec3cfbaa435a7dac4048810.tar.bz2
gentoo-8119d73192a628b59ec3cfbaa435a7dac4048810.zip
sci-physics/vgm: Add 5.1 (supports >=sci-physics/geant-4.11.1.0 )
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/vgm')
-rw-r--r--sci-physics/vgm/Manifest1
-rw-r--r--sci-physics/vgm/vgm-5.1.ebuild81
-rw-r--r--sci-physics/vgm/vgm-9999.ebuild7
3 files changed, 85 insertions, 4 deletions
diff --git a/sci-physics/vgm/Manifest b/sci-physics/vgm/Manifest
index 4208e434d3ad..c165d33f3e7f 100644
--- a/sci-physics/vgm/Manifest
+++ b/sci-physics/vgm/Manifest
@@ -1 +1,2 @@
DIST vgm-5.0.tar.gz 3862583 BLAKE2B 7a1643b329f6f6b019e1b68ce691ed45a32d343925c59451d6e218469606a7a352334d4f1e330873fa1cbc4e1182b4557dc396f52ce7d35e26df81e79121cd60 SHA512 771c2e013c052ea1785fb79ba317b48482428ddf703e263eaf1c9840fbae66dd280d73aee99de30e1c3d70e46a5eb63affc92dfc5ba19298e2d4487b9e302588
+DIST vgm-5.1.tar.gz 3871449 BLAKE2B 19dc9337700edaa854a69b435e6e3012d12762fcc6fe2f3f1799ed11709a04c1b2e6b011ba2de89b251af6bb3471d6969037f4572e51bc21ae1de6cfcb2a3e6f SHA512 ac45c031d3e72d171a1d5048aa2d9e1330574a62cb80caa82a2875dfea4d52a314a7c52d4da99b387f6aeb4ce62842776216447082f8d594182210d34bf567ac
diff --git a/sci-physics/vgm/vgm-5.1.ebuild b/sci-physics/vgm/vgm-5.1.ebuild
new file mode 100644
index 000000000000..5f58d81f0baf
--- /dev/null
+++ b/sci-physics/vgm/vgm-5.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1- -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="Virtual Geometry Model for High Energy Physics Experiments"
+HOMEPAGE="https://github.com/vmc-project/vgm/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc examples +geant4 +root test"
+
+RDEPEND="
+ sci-physics/clhep:=
+ geant4? ( >=sci-physics/geant-4.11:=[c++17] )
+ root? ( sci-physics/root:=[c++17] )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ test? (
+ >=sci-physics/geant-4.11:=[gdml]
+ sci-physics/geant4_vmc[g4root]
+ )"
+RESTRICT="
+ !geant4? ( test )
+ !root? ( test )
+ !test? ( test )
+ !examples? ( test )"
+
+DOCS=(
+ doc/README
+ doc/VGMhistory.txt
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLHEP_DIR="${EPREFIX}/usr"
+ -DWITH_EXAMPLES="$(usex examples)"
+ -DINSTALL_EXAMPLES="$(usex examples)"
+ -DWITH_GEANT4="$(usex geant4)"
+ -DWITH_ROOT="$(usex root)"
+ -DWITH_TEST="$(usex test)"
+ )
+ if use test && use root && use geant4; then
+ mycmakeargs+=( -DWITH_G4ROOT=yes )
+ else
+ mycmakeargs+=( -DWITH_G4ROOT=no )
+ fi
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ doxygen packages/Doxyfile || die
+ fi
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/test || die
+ # See upstream issue: https://github.com/vmc-project/vgm/issues/5
+ sed -i 's/ ScaledSolids / /' test3_suite.sh || die
+ PATH="${BUILD_DIR}"/test:${PATH} ./test_suite.sh || die
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+}
diff --git a/sci-physics/vgm/vgm-9999.ebuild b/sci-physics/vgm/vgm-9999.ebuild
index fdf095918a01..777ea264b4d8 100644
--- a/sci-physics/vgm/vgm-9999.ebuild
+++ b/sci-physics/vgm/vgm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,12 +24,12 @@ IUSE="doc examples +geant4 +root test"
RDEPEND="
sci-physics/clhep:=
- geant4? ( sci-physics/geant[c++17] )
+ geant4? ( sci-physics/geant:=[c++17] )
root? ( sci-physics/root:=[c++17] )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? (
- sci-physics/geant[gdml]
+ sci-physics/geant:=[gdml]
sci-physics/geant4_vmc[g4root]
)"
RESTRICT="
@@ -41,7 +41,6 @@ RESTRICT="
DOCS=(
doc/README
doc/VGMhistory.txt
- doc/todo.txt
)
src_configure() {