summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-06-23 07:11:15 +0700
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-03 12:10:22 +0200
commitc1ce4c24fd0ccea53497f7563e5d0d59ffbf5a0d (patch)
treee76adb70fbf7433005869c5df2812c434683b0fa /sci-physics/yoda
parentapp-arch/stenc: Drop old (diff)
downloadgentoo-c1ce4c24fd0ccea53497f7563e5d0d59ffbf5a0d.tar.gz
gentoo-c1ce4c24fd0ccea53497f7563e5d0d59ffbf5a0d.tar.bz2
gentoo-c1ce4c24fd0ccea53497f7563e5d0d59ffbf5a0d.zip
sci-physics/yoda: Bump to 1.9.5 and EAPI 8
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://bugs.gentoo.org/851540 Closes: https://github.com/gentoo/gentoo/pull/26048 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics/yoda')
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/yoda-1.9.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index 3b97f8db6071..0dfe8252bde5 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1 +1,2 @@
DIST YODA-1.9.0.tar.bz2 1061105 BLAKE2B 70d68d31456747fcb14e27585aae245930061b5135b8a96c8ff3fe0375175d00a1c2d24a6c1ca3f18fc8464e610ef6287184f3990e12ff3fb108def600e34189 SHA512 eb82f1df832c2124dd81e07c06f165ddf13c4c4b70fcd0113f85045e22085d82751325bc57bfbd167649580980d98a15b666de56dada639160f24682b58b2f71
+DIST YODA-1.9.5.tar.bz2 1077442 BLAKE2B 010ab725c57dfab8160e0304d461dc44c140d1ce234f3b70834ee58b8f269159529122095a94e6b79ef752612a6659a17e1874fda2941cfbcec1f53802916b6a SHA512 46e30b33d369f5d28ec228b71eaa298f3010cc06fe568785c74bbaf3d7468c26738cc2ee40da9bcc54d978f394187a2ee9289197283c86a3358583a3c0ecd247
diff --git a/sci-physics/yoda/yoda-1.9.5.ebuild b/sci-physics/yoda/yoda-1.9.5.ebuild
new file mode 100644
index 000000000000..e21cc066b474
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.9.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="root"
+
+RDEPEND="root? ( sci-physics/root:= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P^^}"
+
+src_configure() {
+ econf \
+ --disable-pyext \
+ --disable-static \
+ $(use_enable root)
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools
+ emake check PYTESTS= SHTESTS=
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ newbashcomp "${ED}"/etc/bash_completion.d/yoda-completion yoda
+ rm "${ED}"/etc/bash_completion.d/yoda-completion || die
+}