summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-14 19:00:57 +0000
committerSam James <sam@gentoo.org>2021-06-14 22:11:13 +0000
commitdc8fb78b8b544c68940f26e4e61aacd9efdd1ad5 (patch)
tree2a5764ac7bd27646a2bf742881a333cc8ca64b98 /sci-physics/yoda
parentdev-libs/xapian: fix build with GCC 11 in 1.4.17 (diff)
downloadgentoo-dc8fb78b8b544c68940f26e4e61aacd9efdd1ad5.tar.gz
gentoo-dc8fb78b8b544c68940f26e4e61aacd9efdd1ad5.tar.bz2
gentoo-dc8fb78b8b544c68940f26e4e61aacd9efdd1ad5.zip
sci-physics/yoda: add 1.9.0
Closes: https://bugs.gentoo.org/786909 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-physics/yoda')
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/yoda-1.9.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index bb6ac4b17708..9ec1a49f33af 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1 +1,2 @@
DIST YODA-1.8.5.tar.bz2 1057576 BLAKE2B 3c6abb680afcfb8250c3ae340a1b1307cb5498b726199ecf9afe593fc49c4099fd2b4ac881568c303abd10c22fcf91ffae4283021443fc6230456376617f0de1 SHA512 d1fffa55af069f894b3c88bcd105f77a3105095281febf9c06c0cea2fadea6c63d69df5bde4aa96646d2d560bd83cade6802d9ed19d5a30553cd003ace19dfc8
+DIST YODA-1.9.0.tar.bz2 1061105 BLAKE2B 70d68d31456747fcb14e27585aae245930061b5135b8a96c8ff3fe0375175d00a1c2d24a6c1ca3f18fc8464e610ef6287184f3990e12ff3fb108def600e34189 SHA512 eb82f1df832c2124dd81e07c06f165ddf13c4c4b70fcd0113f85045e22085d82751325bc57bfbd167649580980d98a15b666de56dada639160f24682b58b2f71
diff --git a/sci-physics/yoda/yoda-1.9.0.ebuild b/sci-physics/yoda/yoda-1.9.0.ebuild
new file mode 100644
index 000000000000..eccb09af10af
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="root"
+
+RDEPEND="root? ( sci-physics/root:= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P^^}"
+
+src_configure() {
+ econf \
+ --disable-pyext \
+ --disable-static \
+ $(use_enable root)
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools
+ emake check PYTESTS= SHTESTS=
+}
+
+src_install() {
+ default
+
+ newbashcomp "${ED}"/etc/bash_completion.d/yoda-completion yoda
+ rm "${ED}"/etc/bash_completion.d/yoda-completion || die
+}