summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-11-19 09:58:22 +0100
committerGuilherme Amadio <amadio@gentoo.org>2020-11-19 16:35:59 +0100
commit29b5e3eb423b5f52518941765dc6326f578f87ef (patch)
tree3837a6f80dff19603b1aeced50b109a074cc335d /sci-physics
parentdev-util/cmake: Bump to version 3.19.0. Removed old (diff)
downloadgentoo-29b5e3eb423b5f52518941765dc6326f578f87ef.tar.gz
gentoo-29b5e3eb423b5f52518941765dc6326f578f87ef.tar.bz2
gentoo-29b5e3eb423b5f52518941765dc6326f578f87ef.zip
sci-physics/clhep: fix bug 755476
Closes: https://bugs.gentoo.org/755476 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/clhep-2.4.4.0.ebuild5
-rw-r--r--sci-physics/clhep/files/clhep-modulemap.patch24
2 files changed, 28 insertions, 1 deletions
diff --git a/sci-physics/clhep/clhep-2.4.4.0.ebuild b/sci-physics/clhep/clhep-2.4.4.0.ebuild
index 3d785fcc1662..1938b34ce53a 100644
--- a/sci-physics/clhep/clhep-2.4.4.0.ebuild
+++ b/sci-physics/clhep/clhep-2.4.4.0.ebuild
@@ -26,7 +26,10 @@ BDEPEND="
)
"
-PATCHES=( "${FILESDIR}"/clhep-fix-testThreaded.patch )
+PATCHES=(
+ "${FILESDIR}"/clhep-fix-testThreaded.patch
+ "${FILESDIR}"/clhep-modulemap.patch
+)
S="${WORKDIR}/${PV}/CLHEP"
diff --git a/sci-physics/clhep/files/clhep-modulemap.patch b/sci-physics/clhep/files/clhep-modulemap.patch
new file mode 100644
index 000000000000..31b1eda620a7
--- /dev/null
+++ b/sci-physics/clhep/files/clhep-modulemap.patch
@@ -0,0 +1,24 @@
+From ade5d82b54d2c72660b6b2c478323ac741ea7c01 Mon Sep 17 00:00:00 2001
+From: Guilherme Amadio <amadio@cern.ch>
+Date: Thu, 19 Nov 2020 09:55:12 +0100
+Subject: [PATCH] Install modulemap along with other header files
+
+---
+ cmake/Modules/ClhepCopyHeaders.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/Modules/ClhepCopyHeaders.cmake b/cmake/Modules/ClhepCopyHeaders.cmake
+index bd38b8a2..c6483c3a 100644
+--- a/cmake/Modules/ClhepCopyHeaders.cmake
++++ b/cmake/Modules/ClhepCopyHeaders.cmake
+@@ -49,6 +49,6 @@ macro (clhep_copy_headers )
+ # handle the module.modulemap file
+ CONFIGURE_FILE( ${CLHEP_SOURCE_DIR}/module.modulemap ${CLHEP_BINARY_DIR}/module.modulemap COPYONLY )
+ INSTALL (FILES ${CLHEP_BINARY_DIR}/module.modulemap
+- DESTINATION include )
++ DESTINATION include/CLHEP )
+
+ endmacro (clhep_copy_headers)
+--
+2.29.2
+