summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-10 16:43:40 -0400
committerSam James <sam@gentoo.org>2024-03-11 14:22:42 +0000
commit32cd8f0990a3339ac81408f285578e671c1c6a18 (patch)
tree15b3807955b6aff962c0298fa1bd60e0c68611ff /sci-physics
parentx11-misc/xfractint: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-32cd8f0990a3339ac81408f285578e671c1c6a18.tar.gz
gentoo-32cd8f0990a3339ac81408f285578e671c1c6a18.tar.bz2
gentoo-32cd8f0990a3339ac81408f285578e671c1c6a18.zip
sci-physics/bullet: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/863275 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/bullet-3.21.ebuild10
-rw-r--r--sci-physics/bullet/bullet-3.22b.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/sci-physics/bullet/bullet-3.21.ebuild b/sci-physics/bullet/bullet-3.21.ebuild
index ba59abb141b6..9a61fccf6b25 100644
--- a/sci-physics/bullet/bullet-3.21.ebuild
+++ b/sci-physics/bullet/bullet-3.21.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="Continuous Collision Detection and Physics Library"
HOMEPAGE="https://www.bulletphysics.com/"
@@ -54,6 +54,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror-strict-aliasing
+ # https://bugs.gentoo.org/863275
+ # https://github.com/bulletphysics/bullet3/issues/4590
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DBUILD_CPU_DEMOS=OFF
-DBUILD_OPENGL3_DEMOS=OFF
diff --git a/sci-physics/bullet/bullet-3.22b.ebuild b/sci-physics/bullet/bullet-3.22b.ebuild
index c89db12f8617..dc16ccdb4491 100644
--- a/sci-physics/bullet/bullet-3.22b.ebuild
+++ b/sci-physics/bullet/bullet-3.22b.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="Continuous Collision Detection and Physics Library"
HOMEPAGE="https://pybullet.org/wordpress/"
@@ -52,6 +52,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror-strict-aliasing
+ # https://bugs.gentoo.org/863275
+ # https://github.com/bulletphysics/bullet3/issues/4590
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DBUILD_CPU_DEMOS=OFF
-DBUILD_OPENGL3_DEMOS=OFF